summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-13 19:45:15 +0100
committerSam James <sam@gentoo.org>2022-09-13 19:45:23 +0100
commitabadda5a754ae656af46a3a02f7bedc50343a797 (patch)
tree0f8933f3aaf11c571b49da75b1f967e62629d838 /dev-libs/boehm-gc
parentnet-libs/webkit-gtk: Drop old versions (diff)
downloadgentoo-abadda5a754ae656af46a3a02f7bedc50343a797.tar.gz
gentoo-abadda5a754ae656af46a3a02f7bedc50343a797.tar.bz2
gentoo-abadda5a754ae656af46a3a02f7bedc50343a797.zip
dev-libs/boehm-gc: fix configure tests with Clang 15
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/boehm-gc')
-rw-r--r--dev-libs/boehm-gc/boehm-gc-8.2.2-r1.ebuild63
-rw-r--r--dev-libs/boehm-gc/files/boehm-gc-8.2.2-clang-15-configure.patch43
2 files changed, 106 insertions, 0 deletions
diff --git a/dev-libs/boehm-gc/boehm-gc-8.2.2-r1.ebuild b/dev-libs/boehm-gc/boehm-gc-8.2.2-r1.ebuild
new file mode 100644
index 000000000000..28f0b8b30a27
--- /dev/null
+++ b/dev-libs/boehm-gc/boehm-gc-8.2.2-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# autotools for Clang 15 configure patch
+inherit autotools multilib-minimal #libtool
+
+MY_P="gc-${PV}"
+
+DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
+HOMEPAGE="https://www.hboehm.info/gc/ https://github.com/ivmai/bdwgc/"
+SRC_URI="https://github.com/ivmai/bdwgc/releases/download/v${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="boehm-gc"
+# SONAME: libgc.so.1 libgccpp.so.1
+# We've been using subslot 0 for these instead of "1.1".
+SLOT="0"
+# Upstream marked this version as "Pre-release"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="cxx +large static-libs +threads"
+
+RDEPEND=">=dev-libs/libatomic_ops-7.4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-8.2.2-clang-15-configure.patch
+)
+
+src_prepare() {
+ default
+
+ # bug #594754
+ #elibtoolize
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local config=(
+ --disable-docs
+ --with-libatomic-ops
+ $(use_enable cxx cplusplus)
+ $(use_enable static-libs static)
+ $(use threads || echo --disable-threads)
+ $(use_enable large large-config)
+ )
+
+ ECONF_SOURCE="${S}" econf "${config[@]}"
+}
+
+multilib_src_install_all() {
+ local HTML_DOCS=( doc/*.md )
+ einstalldocs
+ dodoc doc/README{.environment,.linux,.macros}
+
+ # Package provides .pc files
+ find "${ED}" -name '*.la' -delete || die
+
+ newman doc/gc.man GC_malloc.1
+}
diff --git a/dev-libs/boehm-gc/files/boehm-gc-8.2.2-clang-15-configure.patch b/dev-libs/boehm-gc/files/boehm-gc-8.2.2-clang-15-configure.patch
new file mode 100644
index 000000000000..87045eaa912f
--- /dev/null
+++ b/dev-libs/boehm-gc/files/boehm-gc-8.2.2-clang-15-configure.patch
@@ -0,0 +1,43 @@
+https://github.com/ivmai/bdwgc/pull/474
+
+From b3428e52cb9af18d6c85d0027b9c86e9b44e2e4f Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 13 Sep 2022 19:37:59 +0100
+Subject: [PATCH] Fix configure with Clang 15 (implicit function declarations)
+
+Clang 15 makes implicit function declarations an error by default
+which leads to configure falsely thinking `pthread_setname_np` is
+not present:
+```
+checking for pthread_setname_np... no
+```
+
+This fixes that issue and the following errors:
+```
+error: call to undeclared function 'pthread_setname_np'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
+error: call to undeclared function 'pthread_setname_np'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
+```
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -834,12 +834,16 @@ AS_IF([test "$THREADS" = posix],
+ [AC_MSG_CHECKING(for pthread_setname_np)
+ old_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $CFLAGS_EXTRA -Werror"
+- AC_TRY_COMPILE([#include <pthread.h>],
++ AC_TRY_COMPILE([
++#define _GNU_SOURCE 1
++#include <pthread.h>],
+ [pthread_setname_np("thread-name")],
+ [AC_MSG_RESULT([yes (w/o tid)])
+ AC_DEFINE([HAVE_PTHREAD_SETNAME_NP_WITHOUT_TID], [1],
+ [Define to use 'pthread_setname_np(const char*)' function.])],
+- [AC_TRY_COMPILE([#include <pthread.h>],
++ [AC_TRY_COMPILE([
++#define _GNU_SOURCE 1
++#include <pthread.h>],
+ [pthread_setname_np(pthread_self(), "thread-name-%u", 0)],
+ [AC_MSG_RESULT([yes (with tid and arg)])
+ AC_DEFINE([HAVE_PTHREAD_SETNAME_NP_WITH_TID_AND_ARG], [1],
+