summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-21 13:54:58 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-21 13:54:58 +0100
commit81a235b7d29509360c6c2df3c75093261c2748f4 (patch)
tree04e9a12457a4a2374c1449b448cbd0ce0b212a87 /dev-libs/boost
parentprofiles/package.deprecated: Add a removal date for virtual/emacs. (diff)
downloadgentoo-81a235b7d29509360c6c2df3c75093261c2748f4.tar.gz
gentoo-81a235b7d29509360c6c2df3c75093261c2748f4.tar.bz2
gentoo-81a235b7d29509360c6c2df3c75093261c2748f4.zip
dev-libs/boost: Fix Boost.Bimap headers
Bug: https://bugs.gentoo.org/703294 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/boost-1.72.0.ebuild2
-rw-r--r--dev-libs/boost/files/boost-1.72.0-missing-serialization-split_member-include.patch29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/boost/boost-1.72.0.ebuild b/dev-libs/boost/boost-1.72.0.ebuild
index 7434b5bd5d16..31a72e017073 100644
--- a/dev-libs/boost/boost-1.72.0.ebuild
+++ b/dev-libs/boost/boost-1.72.0.ebuild
@@ -54,6 +54,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.71.0-disable_icu_rpath.patch
"${FILESDIR}"/${PN}-1.71.0-context-x32.patch
"${FILESDIR}"/${PN}-1.71.0-build-auto_index-tool.patch
+ # Bug 703294, incomplete Boost.Serialization refactoring
+ "${FILESDIR}"/${PN}-1.72.0-missing-serialization-split_member-include.patch
)
python_bindings_needed() {
diff --git a/dev-libs/boost/files/boost-1.72.0-missing-serialization-split_member-include.patch b/dev-libs/boost/files/boost-1.72.0-missing-serialization-split_member-include.patch
new file mode 100644
index 000000000000..0c9f72583efd
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.72.0-missing-serialization-split_member-include.patch
@@ -0,0 +1,29 @@
+Missing #include, as the split_member.hpp include is not
+part of the nvp.hpp interface, and hence cannot be relied
+upon to be included transitively.
+
+Confirmed on
+https://github.com/boostorg/serialization/commit/c32a663c9963385430abc563f9c85f94d8da43a9#r36528430
+
+Bug: https://bugs.gentoo.org/703294
+
+--- a/boost/bimap/detail/map_view_iterator.hpp
++++ b/boost/bimap/detail/map_view_iterator.hpp
+@@ -22,6 +22,7 @@
+
+ #ifndef BOOST_BIMAP_DISABLE_SERIALIZATION
+ #include <boost/serialization/nvp.hpp>
++ #include <boost/serialization/split_member.hpp>
+ #endif // BOOST_BIMAP_DISABLE_SERIALIZATION
+
+ #include <boost/iterator/detail/enable_if.hpp>
+--- a/boost/bimap/detail/set_view_iterator.hpp
++++ b/boost/bimap/detail/set_view_iterator.hpp
+@@ -22,6 +22,7 @@
+
+ #ifndef BOOST_BIMAP_DISABLE_SERIALIZATION
+ #include <boost/serialization/nvp.hpp>
++ #include <boost/serialization/split_member.hpp>
+ #endif // BOOST_BIMAP_DISABLE_SERIALIZATION
+
+ #include <boost/iterator/detail/enable_if.hpp>