summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/c-blosc/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/c-blosc/files')
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch22
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch27
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch b/dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch
new file mode 100644
index 000000000000..484db1f6dd3c
--- /dev/null
+++ b/dev-libs/c-blosc/files/c-blosc-1.3.2-shared-libs.patch
@@ -0,0 +1,22 @@
+--- hdf5/CMakeLists.txt.orig 2014-02-05 16:55:55.001344161 -0800
++++ hdf5/CMakeLists.txt 2014-02-05 16:57:03.767739650 -0800
+@@ -23,16 +23,16 @@
+
+ # install
+ install(FILES blosc_filter.h DESTINATION include COMPONENT HDF5_FILTER_DEV)
+-install(TARGETS blosc_filter_static DESTINATION lib COMPONENT HDF5_FILTER)
++install(TARGETS blosc_filter_shared DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER)
+ if(BUILD_STATIC)
+ install(
+- TARGETS blosc_filter_shared DESTINATION lib COMPONENT HDF5_FILTER_DEV)
++ TARGETS blosc_filter_static DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER_DEV)
+ endif(BUILD_STATIC)
+
+
+ # test
+ if(BUILD_TESTS)
+ add_executable(example example.c)
+- target_link_libraries(example blosc_filter_static ${HDF5_LIBRARIES})
++ target_link_libraries(example blosc_filter_shared ${HDF5_LIBRARIES})
+ add_test(test_hdf5_filter example)
+ endif(BUILD_TESTS)
diff --git a/dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch b/dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch
new file mode 100644
index 000000000000..c46f66987445
--- /dev/null
+++ b/dev-libs/c-blosc/files/c-blosc-1.5.3-shared-libs.patch
@@ -0,0 +1,27 @@
+ hdf5/CMakeLists.txt | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/hdf5/CMakeLists.txt b/hdf5/CMakeLists.txt
+index d91194f..032a292 100644
+--- a/hdf5/CMakeLists.txt
++++ b/hdf5/CMakeLists.txt
+@@ -44,16 +44,16 @@ endif(MSVC)
+
+ # install
+ install(FILES blosc_filter.h DESTINATION include COMPONENT HDF5_FILTER_DEV)
+-install(TARGETS blosc_filter_shared DESTINATION lib COMPONENT HDF5_FILTER)
++install(TARGETS blosc_filter_shared DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER)
+ if(BUILD_STATIC)
+ install(
+- TARGETS blosc_filter_static DESTINATION lib COMPONENT HDF5_FILTER_DEV)
++ TARGETS blosc_filter_static DESTINATION lib${LIB_SUFFIX} COMPONENT HDF5_FILTER_DEV)
+ endif(BUILD_STATIC)
+
+
+ # test
+ if(BUILD_TESTS)
+ add_executable(example example.c)
+- target_link_libraries(example blosc_filter_static ${HDF5_LIBRARIES})
++ target_link_libraries(example blosc_filter_shared ${HDF5_LIBRARIES})
+ add_test(test_hdf5_filter example)
+ endif(BUILD_TESTS)