summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-24 16:25:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-24 16:25:00 +0200
commit92a7f8e62a40540d70d539a874b45604bce084e1 (patch)
tree9613ec5fc076e68bbaa4c5f40fefaa6f0961034b /dev-libs/c-capnproto/files
parentmedia-video/x264-encoder: bump a new snapshot (diff)
downloadgentoo-92a7f8e62a40540d70d539a874b45604bce084e1.tar.gz
gentoo-92a7f8e62a40540d70d539a874b45604bce084e1.tar.bz2
gentoo-92a7f8e62a40540d70d539a874b45604bce084e1.zip
dev-libs/c-capnproto: initial import; ebuild by me
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-libs/c-capnproto/files')
-rw-r--r--dev-libs/c-capnproto/files/gtest.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/c-capnproto/files/gtest.patch b/dev-libs/c-capnproto/files/gtest.patch
new file mode 100644
index 000000000000..b094c5e6f219
--- /dev/null
+++ b/dev-libs/c-capnproto/files/gtest.patch
@@ -0,0 +1,41 @@
+Index: c-capnproto-c-capnproto-0.1/configure.ac
+===================================================================
+--- c-capnproto-c-capnproto-0.1.orig/configure.ac
++++ c-capnproto-c-capnproto-0.1/configure.ac
+@@ -35,8 +35,6 @@ AC_SUBST(WERROR)
+ # AC_MSG_ERROR([capnproto base package (0.5.2 or newer) not found])
+ #])
+
+-AC_CONFIG_SUBDIRS([gtest/googletest])
+-
+ AC_CONFIG_FILES([
+ Makefile
+ c-capnproto.pc
+Index: c-capnproto-c-capnproto-0.1/Makefile.am
+===================================================================
+--- c-capnproto-c-capnproto-0.1.orig/Makefile.am
++++ c-capnproto-c-capnproto-0.1/Makefile.am
+@@ -41,12 +41,6 @@ noinst_HEADERS += \
+ compiler/c++.capnp.h \
+ compiler/test.capnp.h
+
+-GTEST_LDADD = gtest/googletest/lib/libgtest.la
+-gtest/googletest/lib/libgtest.la:
+- make -C gtest/googletest lib/libgtest.la
+-GTEST_CPPFLAGS = -I${srcdir}/gtest/googletest/include
+-DIST_SUBDIRS = gtest/googletest
+-
+ check_PROGRAMS += \
+ capn-test
+ capn_test_SOURCES = \
+@@ -55,8 +49,8 @@ capn_test_SOURCES = \
+ compiler/test.capnp.c \
+ compiler/schema-test.cpp \
+ compiler/schema.capnp.c
+-capn_test_CPPFLAGS = $(AM_CPPFLAGS) $(GTEST_CPPFLAGS)
++capn_test_CPPFLAGS = $(AM_CPPFLAGS)
+ capn_test_CXXFLAGS = -std=gnu++11 -pthread
+-capn_test_LDADD = libcapnp_c.la $(GTEST_LDADD)
++capn_test_LDADD = libcapnp_c.la -lgtest
+ capn_test_LDFLAGS = -pthread
+ TESTS = capn-test