summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-07-17 23:29:58 +0200
committerDavid Seifert <soap@gentoo.org>2021-07-17 23:29:58 +0200
commit28f1e9ee02af19666b6cb1e51190b1375ca13359 (patch)
treef9dd436d6cb42a6ec4b1301a1dc07e52fae3199d /dev-libs/cdk/cdk-5.0.20160131-r1.ebuild
parentdev-lang/ghc: Add sys-libs/ncurses[unicode(+)] (diff)
downloadgentoo-28f1e9ee02af19666b6cb1e51190b1375ca13359.tar.gz
gentoo-28f1e9ee02af19666b6cb1e51190b1375ca13359.tar.bz2
gentoo-28f1e9ee02af19666b6cb1e51190b1375ca13359.zip
dev-libs/cdk: Add sys-libs/ncurses[unicode(+)]
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/cdk/cdk-5.0.20160131-r1.ebuild')
-rw-r--r--dev-libs/cdk/cdk-5.0.20160131-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/cdk/cdk-5.0.20160131-r1.ebuild b/dev-libs/cdk/cdk-5.0.20160131-r1.ebuild
new file mode 100644
index 000000000000..7f12ab36a255
--- /dev/null
+++ b/dev-libs/cdk/cdk-5.0.20160131-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator
+
+MY_P="${PN}-$(replace_version_separator 2 -)"
+DESCRIPTION="A library of curses widgets"
+HOMEPAGE="https://dickey.his.com/cdk/cdk.html"
+SRC_URI="ftp://ftp.invisible-island.net/cdk/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0/6" # subslot = soname version
+KEYWORDS="~alpha amd64 ~arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="examples static-libs unicode"
+
+DEPEND="sys-libs/ncurses:=[unicode(+)?]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-5.0.20120323-parallel-make.patch )
+
+src_configure() {
+ econf \
+ --with-libtool \
+ --with-shared \
+ --with-ncurses$(usex unicode "w" "")
+}
+
+src_install() {
+ # parallel make installs duplicate libs
+ emake -j1 \
+ DESTDIR="${ED}" \
+ DOCUMENT_DIR="${ED}/usr/share/doc/${PF}" install
+
+ if use examples ; then
+ for x in include c++ demos examples cli cli/utils cli/samples; do
+ docinto $x
+ find $x -maxdepth 1 -mindepth 1 -type f -print0 | xargs -0 dodoc
+ done
+ fi
+
+ use static-libs || find "${ED}" \( -name '*.a' -or -name '*.la' \) -delete
+}