summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-11-02 12:48:00 +0100
committerJeroen Roovers <jer@gentoo.org>2018-11-02 15:33:52 +0100
commit5d4cc04ca85a003204616ab3a484b40822f6ebc6 (patch)
tree8e763d429679672ae6010d00509d2ac0c42b243c /dev-libs/cgilib
parentsys-auth/polkit-qt: Drop USE examples (diff)
downloadgentoo-5d4cc04ca85a003204616ab3a484b40822f6ebc6.tar.gz
gentoo-5d4cc04ca85a003204616ab3a484b40822f6ebc6.tar.bz2
gentoo-5d4cc04ca85a003204616ab3a484b40822f6ebc6.zip
dev-libs/cgilib: Drop autotools-utils.eclass
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'dev-libs/cgilib')
-rw-r--r--dev-libs/cgilib/cgilib-0.7-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-libs/cgilib/cgilib-0.7-r1.ebuild b/dev-libs/cgilib/cgilib-0.7-r1.ebuild
new file mode 100644
index 000000000000..1f29dddb4b3d
--- /dev/null
+++ b/dev-libs/cgilib/cgilib-0.7-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A simple and lightweight interface to the CGI for C and C++ programs"
+HOMEPAGE="http://www.infodrom.org/projects/cgilib/"
+SRC_URI="${HOMEPAGE}download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DOCS=( AUTHORS ChangeLog README cookies.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}