summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-03-23 15:12:07 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-03-23 15:13:50 +0200
commit06d2b112fde3faca9767a93835c07009ada5b177 (patch)
treee0676f46625b04f77d5c699376d56e7e543df628 /dev-libs/check/files
parentnet-analyzer/ntopng: Depend on dev-libs/hiredis:= (diff)
downloadgentoo-06d2b112fde3faca9767a93835c07009ada5b177.tar.gz
gentoo-06d2b112fde3faca9767a93835c07009ada5b177.tar.bz2
gentoo-06d2b112fde3faca9767a93835c07009ada5b177.zip
dev-libs/check: update subunit logic, fix pkgconfig file
- subunit & doc handling patches from #711390 - .pc libdir issue when using multilib #714058 Bug: https://bugs.gentoo.org/711390 Closes: https://bugs.gentoo.org/714058 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/check/files')
-rw-r--r--dev-libs/check/files/check-0.14.0-r2-disable-automagic-dep.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/check/files/check-0.14.0-r2-disable-automagic-dep.patch b/dev-libs/check/files/check-0.14.0-r2-disable-automagic-dep.patch
new file mode 100644
index 000000000000..0843413ee2e9
--- /dev/null
+++ b/dev-libs/check/files/check-0.14.0-r2-disable-automagic-dep.patch
@@ -0,0 +1,23 @@
+--- a/CMakeLists.txt 2020-03-21 09:42:30.411037664 +0200
++++ b/CMakeLists.txt 2020-03-21 09:49:12.358161439 +0200
+@@ -365,15 +365,16 @@
+ ADD_DEFINITIONS(-DHAVE_LIBRT=1)
+ endif (HAVE_LIBRT)
+
+-check_library_exists(subunit subunit_test_start "" HAVE_SUBUNIT)
+-if (HAVE_SUBUNIT)
++option(CHECK_ENABLE_SUBUNIT "Enable subunit support" ON)
++if (CHECK_ENABLE_SUBUNIT)
+ set(SUBUNIT "subunit")
+ set(ENABLE_SUBUNIT 1)
++ set(HAVE_SUBUNIT 1)
+ add_definitions(-DENABLE_SUBUNIT=1)
+-else(HAVE_SUBUNIT)
++else(CHECK_ENABLE_SUBUNIT)
+ set(ENABLE_SUBUNIT 0)
+ add_definitions(-DENABLE_SUBUNIT=0)
+-endif (HAVE_SUBUNIT)
++endif (CHECK_ENABLE_SUBUNIT)
+
+ ###############################################################################
+ # Generate "config.h" from "cmake/config.h.in"