summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-03-21 10:52:58 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-03-21 10:53:30 +0200
commit6c5026b88f869f521d85d6a130982c2e92f63e75 (patch)
tree556616ea6c14a3641bb8dc2b5ce6c41bdeb49893 /dev-libs/check/files
parentdev-util/pycharm-professional: Version bump (v2019.3.4) (diff)
downloadgentoo-6c5026b88f869f521d85d6a130982c2e92f63e75.tar.gz
gentoo-6c5026b88f869f521d85d6a130982c2e92f63e75.tar.bz2
gentoo-6c5026b88f869f521d85d6a130982c2e92f63e75.zip
dev-libs/check: migrate to CMake, "fix" tests, revbump 0.14.0
Bug: https://bugs.gentoo.org/711390 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/check/files')
-rw-r--r--dev-libs/check/files/check-0.14.0-r1-disable-automagic-dep.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/check/files/check-0.14.0-r1-disable-automagic-dep.patch b/dev-libs/check/files/check-0.14.0-r1-disable-automagic-dep.patch
new file mode 100644
index 000000000000..a79a7bcccddb
--- /dev/null
+++ b/dev-libs/check/files/check-0.14.0-r1-disable-automagic-dep.patch
@@ -0,0 +1,23 @@
+--- a/CMakeLists.txt 2020-03-21 09:42:30.411037664 +0200
++++ b/CMakeLists.txt 2020-03-21 09:49:12.358161439 +0200
+@@ -365,15 +365,16 @@
+ ADD_DEFINITIONS(-DHAVE_LIBRT=1)
+ endif (HAVE_LIBRT)
+
+-check_library_exists(subunit subunit_test_start "" HAVE_SUBUNIT)
+-if (HAVE_SUBUNIT)
++option(CHECK_ENABLE_SUBUNIT "Enable subunit support" ON)
++if (CHECK_ENABLE_SUBUNIT EQUAL 1)
+ set(SUBUNIT "subunit")
+ set(ENABLE_SUBUNIT 1)
++ set(HAVE_SUBUNIT 1)
+ add_definitions(-DENABLE_SUBUNIT=1)
+-else(HAVE_SUBUNIT)
++else(CHECK_ENABLE_SUBUNIT EQUAL 0)
+ set(ENABLE_SUBUNIT 0)
+ add_definitions(-DENABLE_SUBUNIT=0)
+-endif (HAVE_SUBUNIT)
++endif (CHECK_ENABLE_SUBUNIT)
+
+ ###############################################################################
+ # Generate "config.h" from "cmake/config.h.in"