summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-06-23 06:52:23 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-07-15 18:58:17 +0200
commit4ff9c10ea72790d1d7b2dd8c2c65d42cd10f238a (patch)
tree61599f93451b852ca05d2ae618881eac3684118d /dev-libs/clipper
parentdev-ros/qt_dotgraph: Remove old (diff)
downloadgentoo-4ff9c10ea72790d1d7b2dd8c2c65d42cd10f238a.tar.gz
gentoo-4ff9c10ea72790d1d7b2dd8c2c65d42cd10f238a.tar.bz2
gentoo-4ff9c10ea72790d1d7b2dd8c2c65d42cd10f238a.zip
dev-libs/clipper: added new ebuild
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-libs/clipper')
-rw-r--r--dev-libs/clipper/Manifest1
-rw-r--r--dev-libs/clipper/clipper-6.4.2.ebuild33
-rw-r--r--dev-libs/clipper/metadata.xml15
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/clipper/Manifest b/dev-libs/clipper/Manifest
new file mode 100644
index 000000000000..1a844b9607da
--- /dev/null
+++ b/dev-libs/clipper/Manifest
@@ -0,0 +1 @@
+DIST clipper-6.4.2.zip 2535706 BLAKE2B 755dcfd759888bda7114af784d9e684f36ce8f6e43dcadf07f5797e3723d392aab2ea9b80cb212b7eb3177bfb306ca20a797546cb2c382132887e62fa0dffd93 SHA512 ffc88818c44a38aa278d5010db6cfd505796f39664919f1e48c7fa9267563f62135868993e88f7246dcd688241d1172878e4a008a390648acb99738452e3e5dd
diff --git a/dev-libs/clipper/clipper-6.4.2.ebuild b/dev-libs/clipper/clipper-6.4.2.ebuild
new file mode 100644
index 000000000000..cc85916233e0
--- /dev/null
+++ b/dev-libs/clipper/clipper-6.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit cmake
+
+MY_PV="ver${PV}"
+MY_P="${PN}_${MY_PV}"
+
+DESCRIPTION="Polygon and line clipping and offsetting library (C++, C#, Delphi)"
+HOMEPAGE="http://www.angusj.com/delphi/clipper.php"
+SRC_URI="mirror://sourceforge/project/polyclipping/${MY_P}.zip -> ${P}.zip"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND=""
+BDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/cpp"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+} \ No newline at end of file
diff --git a/dev-libs/clipper/metadata.xml b/dev-libs/clipper/metadata.xml
new file mode 100644
index 000000000000..ca62f48d80f9
--- /dev/null
+++ b/dev-libs/clipper/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ The Clipper library performs line &amp; polygon clipping - intersection, union, difference &amp; exclusive-or,
+ and line &amp; polygon offsetting. The library is based on Vatti's clipping algorithm.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">polyclipping</remote-id>
+ </upstream>
+</pkgmetadata>