summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-10 04:56:05 +0000
committerSam James <sam@gentoo.org>2020-10-10 04:57:18 +0000
commitd5df22ae03be4fd744e3741843a9602ca51afb61 (patch)
tree9bfc7aa84714ba2c0cf56989414986dfe005b9cc /dev-libs/cloog
parentdev-libs/cloog: drop old broken version (diff)
downloadgentoo-d5df22ae03be4fd744e3741843a9602ca51afb61.tar.gz
gentoo-d5df22ae03be4fd744e3741843a9602ca51afb61.tar.bz2
gentoo-d5df22ae03be4fd744e3741843a9602ca51afb61.zip
dev-libs/cloog: minor fixes
* Drop eutils * Add subslot operators * Simplify src_test Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/cloog')
-rw-r--r--dev-libs/cloog/cloog-0.20.0.ebuild11
-rw-r--r--dev-libs/cloog/cloog-9999.ebuild11
2 files changed, 8 insertions, 14 deletions
diff --git a/dev-libs/cloog/cloog-0.20.0.ebuild b/dev-libs/cloog/cloog-0.20.0.ebuild
index cf8d94e57868..590340afe675 100644
--- a/dev-libs/cloog/cloog-0.20.0.ebuild
+++ b/dev-libs/cloog/cloog-0.20.0.ebuild
@@ -3,12 +3,10 @@
EAPI="7"
-inherit autotools eutils
+inherit autotools
DESCRIPTION="A loop generator for scanning polyhedra"
-HOMEPAGE="http://www.bastoul.net/cloog/
- https://github.com/periscop/cloog
-"
+HOMEPAGE="http://www.bastoul.net/cloog/ https://github.com/periscop/cloog"
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
@@ -24,8 +22,8 @@ SLOT="0/4"
IUSE="static-libs"
RDEPEND="
- dev-libs/gmp
- dev-libs/isl
+ dev-libs/gmp:=
+ dev-libs/isl:=
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -55,6 +53,5 @@ src_configure() {
# The default src_test() fails, so we'll just run these directly
src_test() {
- elog ">>> Test phase [check]: ${CATEGORY}/${PF}"
emake -j1 check
}
diff --git a/dev-libs/cloog/cloog-9999.ebuild b/dev-libs/cloog/cloog-9999.ebuild
index cf8d94e57868..590340afe675 100644
--- a/dev-libs/cloog/cloog-9999.ebuild
+++ b/dev-libs/cloog/cloog-9999.ebuild
@@ -3,12 +3,10 @@
EAPI="7"
-inherit autotools eutils
+inherit autotools
DESCRIPTION="A loop generator for scanning polyhedra"
-HOMEPAGE="http://www.bastoul.net/cloog/
- https://github.com/periscop/cloog
-"
+HOMEPAGE="http://www.bastoul.net/cloog/ https://github.com/periscop/cloog"
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
@@ -24,8 +22,8 @@ SLOT="0/4"
IUSE="static-libs"
RDEPEND="
- dev-libs/gmp
- dev-libs/isl
+ dev-libs/gmp:=
+ dev-libs/isl:=
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
@@ -55,6 +53,5 @@ src_configure() {
# The default src_test() fails, so we'll just run these directly
src_test() {
- elog ">>> Test phase [check]: ${CATEGORY}/${PF}"
emake -j1 check
}