summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-01-31 08:17:24 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-02-03 08:37:53 +0200
commita0111536f393cd3776de329f52d1f3b2ce5dfec4 (patch)
tree09d704cbd903bb6b09cac0ff2bba685741e449fc /dev-libs/concurrencykit/concurrencykit-0.7.0.ebuild
parentnet-im/telegram-desktop-bin: Bump version to 1.9.9 (diff)
downloadgentoo-a0111536f393cd3776de329f52d1f3b2ce5dfec4.tar.gz
gentoo-a0111536f393cd3776de329f52d1f3b2ce5dfec4.tar.bz2
gentoo-a0111536f393cd3776de329f52d1f3b2ce5dfec4.zip
dev-libs/concurrencykit: bump to 0.7.0
Closes: https://bugs.gentoo.org/696418 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/concurrencykit/concurrencykit-0.7.0.ebuild')
-rw-r--r--dev-libs/concurrencykit/concurrencykit-0.7.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/concurrencykit/concurrencykit-0.7.0.ebuild b/dev-libs/concurrencykit/concurrencykit-0.7.0.ebuild
new file mode 100644
index 000000000000..1d7428703ed9
--- /dev/null
+++ b/dev-libs/concurrencykit/concurrencykit-0.7.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="ck"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library with concurrency related algorithms and data structures in C"
+HOMEPAGE="http://concurrencykit.org"
+SRC_URI="https://github.com/concurrencykit/ck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# libck.so name collision #616762
+# these packages have nothing in common
+RDEPEND="!sys-cluster/charm"
+
+# https://github.com/concurrencykit/ck/issues/147
+# https://github.com/concurrencykit/ck/issues/150
+PATCHES=(
+ "${FILESDIR}/${PN}-glibc-2.30.patch"
+ "${FILESDIR}/${PN}-doc.patch"
+)
+
+S="${WORKDIR}/${MY_P}"