summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-08-25 23:24:26 +0200
committerDavid Seifert <soap@gentoo.org>2018-08-25 23:24:26 +0200
commit22369d802f6c5ff8a0ba9d69d0c72aff796f4d0a (patch)
treeb18c873cc3438c9f75717a333abf269298a1f7b8 /dev-libs/cppcodec/cppcodec-0.2.ebuild
parentdev-cpp/catch: Version bump to 2.3.0 (diff)
downloadgentoo-22369d802f6c5ff8a0ba9d69d0c72aff796f4d0a.tar.gz
gentoo-22369d802f6c5ff8a0ba9d69d0c72aff796f4d0a.tar.bz2
gentoo-22369d802f6c5ff8a0ba9d69d0c72aff796f4d0a.zip
dev-libs/cppcodec: Version bump to 0.2
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-libs/cppcodec/cppcodec-0.2.ebuild')
-rw-r--r--dev-libs/cppcodec/cppcodec-0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/cppcodec/cppcodec-0.2.ebuild b/dev-libs/cppcodec/cppcodec-0.2.ebuild
new file mode 100644
index 000000000000..fe7a12a7e61f
--- /dev/null
+++ b/dev-libs/cppcodec/cppcodec-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils
+
+DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
+HOMEPAGE="https://github.com/tplgy/cppcodec"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tplgy/cppcodec.git"
+
+ # Disable pulling in catch
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/tplgy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ virtual/pkgconfig
+ >=dev-cpp/catch-2.3.0
+ )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}