summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-11-27 17:53:27 +0100
committerDavid Seifert <soap@gentoo.org>2021-11-27 17:53:27 +0100
commitc8a0b2568dd217a3a5906176db7134e002c0d61a (patch)
treeb8123b62a5c864b21ea6e290bc15a030db72e275 /dev-libs/cppcodec
parentsys-libs/libunwind: add link to upstream PR fo bashism patch (diff)
downloadgentoo-c8a0b2568dd217a3a5906176db7134e002c0d61a.tar.gz
gentoo-c8a0b2568dd217a3a5906176db7134e002c0d61a.tar.bz2
gentoo-c8a0b2568dd217a3a5906176db7134e002c0d61a.zip
dev-libs/cppcodec: update EAPI 7 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/cppcodec')
-rw-r--r--dev-libs/cppcodec/cppcodec-0.2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/cppcodec/cppcodec-0.2.ebuild b/dev-libs/cppcodec/cppcodec-0.2.ebuild
index 7bd99656f4df..c378468fac29 100644
--- a/dev-libs/cppcodec/cppcodec-0.2.ebuild
+++ b/dev-libs/cppcodec/cppcodec-0.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake-utils
+inherit cmake
DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
HOMEPAGE="https://github.com/tplgy/cppcodec"
@@ -31,5 +31,5 @@ src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}