summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-09-23 01:17:48 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-09-23 09:52:56 +0300
commit5e708f89285f5d55f5b5dd26618df439e2943591 (patch)
tree0eaf257e5008e2b81a49861f7952e26a9ef33463 /dev-libs/crypto++
parentnet-libs/gnutls: fix CVE-2016-7444 (diff)
downloadgentoo-5e708f89285f5d55f5b5dd26618df439e2943591.tar.gz
gentoo-5e708f89285f5d55f5b5dd26618df439e2943591.tar.bz2
gentoo-5e708f89285f5d55f5b5dd26618df439e2943591.zip
dev-libs/crypto++ - fix minor c++11 issue
Thanks: Peter Levine Bug: 593860 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/crypto++')
-rw-r--r--dev-libs/crypto++/crypto++-5.6.2-r3.ebuild3
-rw-r--r--dev-libs/crypto++/files/crypto++-5.6.2-c++11.patch22
2 files changed, 24 insertions, 1 deletions
diff --git a/dev-libs/crypto++/crypto++-5.6.2-r3.ebuild b/dev-libs/crypto++/crypto++-5.6.2-r3.ebuild
index 57b4f460310d..1932f1a469e0 100644
--- a/dev-libs/crypto++/crypto++-5.6.2-r3.ebuild
+++ b/dev-libs/crypto++/crypto++-5.6.2-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -23,6 +23,7 @@ S="${WORKDIR}"
src_prepare() {
epatch "${FILESDIR}"/${P}-r1-make.patch
epatch "${FILESDIR}"/${P}-cve-2015-2141.patch
+ epatch "${FILESDIR}"/${P}-c++11.patch
# Generate our own libtool script for building.
cat <<-EOF > configure.ac
diff --git a/dev-libs/crypto++/files/crypto++-5.6.2-c++11.patch b/dev-libs/crypto++/files/crypto++-5.6.2-c++11.patch
new file mode 100644
index 000000000000..407503606a33
--- /dev/null
+++ b/dev-libs/crypto++/files/crypto++-5.6.2-c++11.patch
@@ -0,0 +1,22 @@
+From 44015c26ba215f955b1e653f9c8f3c894a532707 Mon Sep 17 00:00:00 2001
+From: Jeffrey Walton <noloader@gmail.com>
+Date: Tue, 9 Jun 2015 09:49:02 -0400
+Subject: [PATCH] Cleared ill-formed conversion in C++11
+
+---
+ wake.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/wake.cpp b/wake.cpp
+index c34165b..e0f194e 100644
+--- a/wake.cpp
++++ b/wake.cpp
+@@ -23,7 +23,7 @@ void WAKE_Base::GenKey(word32 k0, word32 k1, word32 k2, word32 k3)
+ signed int x, z, p;
+ // x and z were declared as "long" in Wheeler's paper, which is a signed type. I don't know if that was intentional, but it's too late to change it now. -- Wei 7/4/2010
+ CRYPTOPP_COMPILE_ASSERT(sizeof(x) == 4);
+- static int tt[10]= {
++ static unsigned int tt[10]= {
+ 0x726a8f3b, // table
+ 0xe69a3b5c,
+ 0xd3c71fe5,