summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-03 22:43:05 +0000
committerSam James <sam@gentoo.org>2021-04-03 22:43:05 +0000
commit85a677251bb7a08cf311f40ba0ca7d35111f813b (patch)
treed1a7d7d33df3354e73fd9580ab99bb07974eb569 /dev-libs/dmalloc/dmalloc-999999.ebuild
parentprofiles/features/prefix: force rust[system-bootstrap] (diff)
downloadgentoo-85a677251bb7a08cf311f40ba0ca7d35111f813b.tar.gz
gentoo-85a677251bb7a08cf311f40ba0ca7d35111f813b.tar.bz2
gentoo-85a677251bb7a08cf311f40ba0ca7d35111f813b.zip
dev-libs/dmalloc: multilib--, static-libs--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/dmalloc/dmalloc-999999.ebuild')
-rw-r--r--dev-libs/dmalloc/dmalloc-999999.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/dev-libs/dmalloc/dmalloc-999999.ebuild b/dev-libs/dmalloc/dmalloc-999999.ebuild
index 8408576bf003..e94bdfb50036 100644
--- a/dev-libs/dmalloc/dmalloc-999999.ebuild
+++ b/dev-libs/dmalloc/dmalloc-999999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools git-r3 multilib toolchain-funcs
+
+inherit autotools git-r3 toolchain-funcs
DESCRIPTION="A Debug Malloc Library"
HOMEPAGE="https://dmalloc.com"
@@ -10,16 +11,17 @@ EGIT_REPO_URI="https://github.com/j256/dmalloc"
LICENSE="ISC"
SLOT="0"
-KEYWORDS=""
-IUSE="static-libs threads"
+IUSE="threads"
BDEPEND="
app-text/texi2html
sys-apps/texinfo
"
+
DOCS=(
ChangeLog.txt README.md TODO dmalloc.html
)
+
PATCHES=(
# - Build objects twice, once -fPIC for shared.
# - Use DESTDIR.
@@ -49,13 +51,16 @@ src_prepare() {
src_configure() {
tc-export AR
- econf --enable-cxx --enable-shlib $(use_enable threads)
+ econf \
+ --enable-cxx \
+ --enable-shlib \
+ $(use_enable threads)
}
src_compile() {
default
-# makeinfo dmalloc.texi || die
+ #makeinfo dmalloc.texi || die
}
src_test() {
@@ -77,7 +82,5 @@ src_install() {
/usr/$(get_libdir)/lib${PN}${lib}.so.5
done
- if ! use static-libs; then
- rm "${ED}"/usr/$(get_libdir)/lib${PN}*.a || die
- fi
+ rm "${ED}"/usr/$(get_libdir)/lib${PN}*.a || die
}