summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcharIes17 <charles17@arcor.de>2018-01-21 19:47:52 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-29 00:26:33 +0100
commitc9fe40f4117d42015253a3771cf1ffca812eb059 (patch)
treeb8004fc65c46001e3b46c07797967839e08f9262 /dev-libs/dotconf/dotconf-1.3-r1.ebuild
parentmedia-sound/jack2-1.9.12-r1: Add USE ieee1394 (diff)
downloadgentoo-c9fe40f4117d42015253a3771cf1ffca812eb059.tar.gz
gentoo-c9fe40f4117d42015253a3771cf1ffca812eb059.tar.bz2
gentoo-c9fe40f4117d42015253a3771cf1ffca812eb059.zip
dev-libs/dotconf: Bump to EAPI=6
repo.eapi.deprecated 1 dev-libs/dotconf/dotconf-1.3.ebuild: 3 Bug: https://bugs.gentoo.org/642274 Closes: https://github.com/gentoo/gentoo/pull/6925 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs/dotconf/dotconf-1.3-r1.ebuild')
-rw-r--r--dev-libs/dotconf/dotconf-1.3-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/dotconf/dotconf-1.3-r1.ebuild b/dev-libs/dotconf/dotconf-1.3-r1.ebuild
new file mode 100644
index 000000000000..22a423f82214
--- /dev/null
+++ b/dev-libs/dotconf/dotconf-1.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="dot.conf configuration file parser"
+HOMEPAGE="https://github.com/williamh/dotconf"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=sys-devel/autoconf-2.58"
+RDEPEND=""
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+pkg_postinst() {
+ ewarn 'This version requires that you run revdep-rebuild after'
+ ewarn 'the upgrade.'
+}