summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-04-08 13:34:13 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-04-08 13:34:42 -0500
commitceb1566397c599b8fe43f349128ee2157c2aafa2 (patch)
tree6e31ef22702fecc583dba6f589e33fecbcc5510c /dev-libs/dotconf/dotconf-9999.ebuild
parentdev-libs/dotconf: style changes (diff)
downloadgentoo-ceb1566397c599b8fe43f349128ee2157c2aafa2.tar.gz
gentoo-ceb1566397c599b8fe43f349128ee2157c2aafa2.tar.bz2
gentoo-ceb1566397c599b8fe43f349128ee2157c2aafa2.zip
dev-libs/dotconf: add live
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-libs/dotconf/dotconf-9999.ebuild')
-rw-r--r--dev-libs/dotconf/dotconf-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/dotconf/dotconf-9999.ebuild b/dev-libs/dotconf/dotconf-9999.ebuild
new file mode 100644
index 000000000000..36d47ae81583
--- /dev/null
+++ b/dev-libs/dotconf/dotconf-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+fi
+inherit autotools toolchain-funcs
+
+DESCRIPTION="dot.conf configuration file parser"
+HOMEPAGE="https://github.com/williamh/dotconf"
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/williamh/dotconf.git"
+else
+ SRC_URI="https://github.com/williamh/dotconf/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+DEPEND=">=dev-build/autoconf-2.58"
+
+src_configure() {
+ eautoreconf
+ econf --disable-static
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}