summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/elfio/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/elfio/files')
-rw-r--r--dev-libs/elfio/files/elfio-1.0.3-shared.patch83
1 files changed, 83 insertions, 0 deletions
diff --git a/dev-libs/elfio/files/elfio-1.0.3-shared.patch b/dev-libs/elfio/files/elfio-1.0.3-shared.patch
new file mode 100644
index 000000000000..01e67dfe98bc
--- /dev/null
+++ b/dev-libs/elfio/files/elfio-1.0.3-shared.patch
@@ -0,0 +1,83 @@
+diff -ur ELFIO-1.0.3.orig/configure.in ELFIO-1.0.3/configure.in
+--- ELFIO-1.0.3.orig/configure.in 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/configure.in 2007-03-06 16:37:08.000000000 +0100
+@@ -7,6 +7,7 @@
+ AC_PROG_CXX
+ AC_PROG_RANLIB
+ AC_PROG_INSTALL
++AC_PROG_LIBTOOL
+
+ dnl Checks for libraries.
+
+diff -ur ELFIO-1.0.3.orig/ELFIO/Makefile.am ELFIO-1.0.3/ELFIO/Makefile.am
+--- ELFIO-1.0.3.orig/ELFIO/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/ELFIO/Makefile.am 2007-03-06 16:36:45.000000000 +0100
+@@ -1,6 +1,6 @@
+-lib_LIBRARIES = libELFIO.a
++lib_LTLIBRARIES = libELFIO.la
+
+-libELFIO_a_SOURCES = ELFIDynamic.cpp ELFIImpl.cpp ELFINote.cpp ELFIO.cpp \
++libELFIO_la_SOURCES = ELFIDynamic.cpp ELFIImpl.cpp ELFINote.cpp ELFIO.cpp \
+ ELFIOUtils.cpp ELFIRelocation.cpp ELFISection.cpp \
+ ELFISegment.cpp ELFIStrings.cpp ELFISymbols.cpp \
+ ELFODynamic.cpp ELFOImpl.cpp ELFONote.cpp \
+@@ -10,4 +10,4 @@
+ include_HEADERS = ELFI.h ELFIO.h ELFO.h ELFTypes.h
+ noinst_HEADERS = ELFIImpl.h ELFOImpl.h ELFIOUtils.h
+
+-EXTRA_DIST = ELFIO.dsp ELFIO.dsw ELFIO.mcp
+\ No newline at end of file
++EXTRA_DIST = ELFIO.dsp ELFIO.dsw ELFIO.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/ELFDump/Makefile.am ELFIO-1.0.3/Examples/ELFDump/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/ELFDump/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/ELFDump/Makefile.am 2007-03-06 16:37:51.000000000 +0100
+@@ -3,6 +3,6 @@
+ bin_PROGRAMS = ELFDump
+
+ ELFDump_SOURCES = ELFDump.cpp
+-ELFDump_LDADD = ../../ELFIO/libELFIO.a
++ELFDump_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = ELFDump.dsp ELFDump.dsw ELFDump.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/RelocationTable/Makefile.am ELFIO-1.0.3/Examples/RelocationTable/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/RelocationTable/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/RelocationTable/Makefile.am 2007-03-06 16:38:53.000000000 +0100
+@@ -3,6 +3,6 @@
+ noinst_PROGRAMS = RelocationTable
+
+ RelocationTable_SOURCES = RelocationTable.cpp
+-RelocationTable_LDADD = ../../ELFIO/libELFIO.a
++RelocationTable_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = RelocationTable.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/WriteObj/Makefile.am ELFIO-1.0.3/Examples/WriteObj/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/WriteObj/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/WriteObj/Makefile.am 2007-03-06 16:39:28.000000000 +0100
+@@ -3,6 +3,6 @@
+ noinst_PROGRAMS = WriteObj
+
+ WriteObj_SOURCES = WriteObj.cpp
+-WriteObj_LDADD = ../../ELFIO/libELFIO.a
++WriteObj_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = WriteObj.dsp WriteObj.dsw WriteObj.mcp
+diff -ur ELFIO-1.0.3.orig/Examples/WriteObj2/Makefile.am ELFIO-1.0.3/Examples/WriteObj2/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/WriteObj2/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/WriteObj2/Makefile.am 2007-03-06 16:39:40.000000000 +0100
+@@ -3,4 +3,4 @@
+ noinst_PROGRAMS = WriteObj2
+
+ WriteObj2_SOURCES = WriteObj2.cpp
+-WriteObj2_LDADD = ../../ELFIO/libELFIO.a
++WriteObj2_LDADD = ../../ELFIO/libELFIO.la
+diff -ur ELFIO-1.0.3.orig/Examples/Writer/Makefile.am ELFIO-1.0.3/Examples/Writer/Makefile.am
+--- ELFIO-1.0.3.orig/Examples/Writer/Makefile.am 2007-03-06 16:36:26.000000000 +0100
++++ ELFIO-1.0.3/Examples/Writer/Makefile.am 2007-03-06 16:39:10.000000000 +0100
+@@ -3,6 +3,6 @@
+ noinst_PROGRAMS = Writer
+
+ Writer_SOURCES = Write.cpp
+-Writer_LDADD = ../../ELFIO/libELFIO.a
++Writer_LDADD = ../../ELFIO/libELFIO.la
+
+ EXTRA_DIST = Writer.dsp Writer.dsw Writer.mcp