summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (t1) <m.mairkeimberger@gmail.com>2017-08-06 17:12:21 +0200
committerSergei Trofimovich <slyfox@gentoo.org>2017-08-07 22:54:56 +0100
commitcf3ebf28d8d512db0060035783672e9f62f6c26e (patch)
tree772f3f76e0f193fcf4886a4b209b94ae06414ed8 /dev-libs/elfutils/elfutils-0.170.ebuild
parentwww-client/google-chrome-beta: automated update (61.0.3163.31) (diff)
downloadgentoo-cf3ebf28d8d512db0060035783672e9f62f6c26e.tar.gz
gentoo-cf3ebf28d8d512db0060035783672e9f62f6c26e.tar.bz2
gentoo-cf3ebf28d8d512db0060035783672e9f62f6c26e.zip
dev-libs/elfutils: Version bump to 0.170
Closes: https://github.com/gentoo/gentoo/pull/5323
Diffstat (limited to 'dev-libs/elfutils/elfutils-0.170.ebuild')
-rw-r--r--dev-libs/elfutils/elfutils-0.170.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/elfutils/elfutils-0.170.ebuild b/dev-libs/elfutils/elfutils-0.170.ebuild
new file mode 100644
index 000000000000..c6b460b456ef
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.170.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic multilib-minimal
+
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="http://elfutils.org/"
+SRC_URI="https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2+ LGPL-3+ ) utils? ( GPL-3+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="bzip2 lzma nls static-libs test +threads +utils"
+
+RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
+ lzma? ( >=app-arch/xz-utils-5.0.5-r1[${MULTILIB_USEDEP}] )
+ !dev-libs/libelf"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=sys-devel/flex-2.5.4a
+ sys-devel/m4"
+
+src_prepare() {
+ default
+ epatch "${FILESDIR}"/${PN}-0.118-PaX-support.patch
+ if use static-libs; then
+ sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die
+ fi
+ sed -i 's:-Werror::' */Makefile.in || die
+}
+
+src_configure() {
+ use test && append-flags -g #407135
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable nls) \
+ $(use_enable threads thread-safety) \
+ --program-prefix="eu-" \
+ --with-zlib \
+ $(use_with bzip2 bzlib) \
+ $(use_with lzma)
+}
+
+multilib_src_test() {
+ env LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \
+ LC_ALL="C" \
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dodoc NOTES
+ # These build quick, and are needed for most tests, so don't
+ # disable their building when the USE flag is disabled.
+ if ! use utils; then
+ rm -rf "${ED}"/usr/bin || die
+ fi
+}