summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-12-28 00:06:28 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-12-28 10:42:22 +0100
commit63a66d7df57fce2fd89755129cbf226506fda820 (patch)
treeef3e0dbc0c4d43e8ce3db398490fcd79cfae239b /dev-libs/ell/ell-0.16.ebuild
parentapp-editors/gvim: version bump to 8.1.0648 (diff)
downloadgentoo-63a66d7df57fce2fd89755129cbf226506fda820.tar.gz
gentoo-63a66d7df57fce2fd89755129cbf226506fda820.tar.bz2
gentoo-63a66d7df57fce2fd89755129cbf226506fda820.zip
dev-libs/ell: Bump to version 0.16
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/ell/ell-0.16.ebuild')
-rw-r--r--dev-libs/ell/ell-0.16.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/ell/ell-0.16.ebuild b/dev-libs/ell/ell-0.16.ebuild
new file mode 100644
index 000000000000..69fc97dbb17b
--- /dev/null
+++ b/dev-libs/ell/ell-0.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Embedded Linux Library provides core, low-level functionality for system daemons"
+HOMEPAGE="https://01.org/ell"
+SRC_URI="https://mirrors.edge.kernel.org/pub/linux/libs/${PN}/${P}.tar.xz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="glib pie"
+
+RDEPEND="
+ glib? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable glib)
+ $(use_enable pie)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ local DOCS=( ChangeLog README )
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+}