summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-05-18 14:55:39 +0100
committerSam James <sam@gentoo.org>2021-12-08 02:03:45 +0000
commite257f3c300909b01309710582e8f09b3d638f864 (patch)
tree31a3df278a3b197d9caa91770fd41fb0fa2612ca /dev-libs/geoip/geoip-1.6.12-r1.ebuild
parentapp-emulation/qemu: drop 6.1.0-r1 (diff)
downloadgentoo-e257f3c300909b01309710582e8f09b3d638f864.tar.gz
gentoo-e257f3c300909b01309710582e8f09b3d638f864.tar.bz2
gentoo-e257f3c300909b01309710582e8f09b3d638f864.zip
dev-libs/geoip: Update geoipupdate.sh to use mirrors
The free databases provided by MaxMind are no longer available and so the script doesn't work. Switch to a different mirror. Suggested-by: Alexander Berkes <office@metasoft.at> Closes: https://bugs.gentoo.org/674852 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/20869 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/geoip/geoip-1.6.12-r1.ebuild')
-rw-r--r--dev-libs/geoip/geoip-1.6.12-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/geoip/geoip-1.6.12-r1.ebuild b/dev-libs/geoip/geoip-1.6.12-r1.ebuild
new file mode 100644
index 000000000000..fd7343e19b73
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.6.12-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="GeoIP Legacy C API"
+HOMEPAGE="https://github.com/maxmind/geoip-api-c"
+SRC_URI="https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-api-c-${PV}"
+
+# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
+LICENSE="LGPL-2.1 GPL-2 MaxMind2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+RESTRICT="test"
+
+DEPEND="net-misc/wget"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+ sed -e "s|@PREFIX@|${EPREFIX}|g" "${FILESDIR}"/geoipupdate-r7.sh > geoipupdate.sh || die
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS.md README*
+
+ find "${ED}" -name '*.la' -delete || die
+
+ keepdir /usr/share/GeoIP
+
+ dosbin geoipupdate.sh
+}
+
+pkg_postinst() {
+ ewarn "WARNING: Databases are no longer installed by this ebuild."
+ elog "Don't forget to run 'geoipupdate.sh -f' (or geoipupdate from"
+ elog "net-misc/geoipupdate) to populate ${EROOT}/usr/share/GeoIP/"
+ elog "with geo-located IP address databases."
+}