summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-09-21 12:12:22 +0200
committerMatt Turner <mattst88@gentoo.org>2022-10-01 11:40:43 -0400
commitac1c345be256b3a3800ace28559aea4f075b0c29 (patch)
treed84dd2491f6d538169c8976e07c5a8ee4973d36c /dev-libs/gjs
parentapp-crypt/gcr: Version bump to 3.92.0 (diff)
downloadgentoo-ac1c345be256b3a3800ace28559aea4f075b0c29.tar.gz
gentoo-ac1c345be256b3a3800ace28559aea4f075b0c29.tar.bz2
gentoo-ac1c345be256b3a3800ace28559aea4f075b0c29.zip
dev-libs/gjs: Version bump to 1.74.0
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/gjs')
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/gjs-1.74.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index af900d8227c2..3122488bf4e7 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,3 +1,4 @@
DIST gjs-1.64.5.tar.xz 422548 BLAKE2B dcc0b7327cbc6a1108be031c8807e61ebd3c8392916750078aaa0d82cb3bf9f7ff0e1876c250e5ddf6e9d7bb6a17d9d1fe34c1c77ff534b7ec1dd54fa05a2d1b SHA512 41a3c79888792674b2bccbf254507ed02497eb571c8ca7f47aab406d2ee29b73c98b1c7d59c33ed33bad90c6989df944d78b86d2f7e9824d598b62e29769b6dc
DIST gjs-1.72.1.tar.xz 620248 BLAKE2B 945b988fdb8c9fc01ec73c8f10b7e5ba9db3ee6dabee65d574b42b7cc9421a0c679f15d565a5e538f6493ed58dc4f9503698b8e3c554704338225d7a748b9594 SHA512 dbceb8651e248ace064d9338d1b3ee1ec0ec835843eb617925b09d77808a71274023d7ad621ed638ff47b93e1fa46e7a349342e555dd6043dc97b81d36bf34e6
DIST gjs-1.72.2.tar.xz 620380 BLAKE2B 5ea15bdf25c36fa0236f03adea5b2261db3923190005754119eacd070830e7baedfa842ab273219055f67f7af535d31d5844c76eddfb03a8ec1cab57297ec258 SHA512 0dd10f40e8811bbb79c541cf3dc4e3759c0e025485e4b8ad2870dc30ac8030573300bc178c78bf2d396b86733e36b33210bfbdeead6a314e592d5b3c250a16a2
+DIST gjs-1.74.0.tar.xz 638064 BLAKE2B d44f323aef9b696c7dab53fb46d6bbf142f83636bff81fe68bd30f1f897a778836d7a388c946cb86e84df15b3908d8ff14f0d994854eb2dce7af2c4e54da299b SHA512 a17947664a2bb83363ec564dcb5e619f241d0b547512042f2c0e49fbbc8ca4217b90e6b22bc2e4004e8f27e013f8520674a493f7cf3b808437b855eee3eb0408
diff --git a/dev-libs/gjs/gjs-1.74.0.ebuild b/dev-libs/gjs/gjs-1.74.0.ebuild
new file mode 100644
index 000000000000..dda2b9c1dcb1
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.74.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic gnome.org meson virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gjs https://gitlab.gnome.org/GNOME/gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples gtk readline sysprof test"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ dev-libs/libffi:=
+ >=dev-libs/gobject-introspection-1.66.1:=
+ >=dev-lang/spidermonkey-102.2.0:102
+ cairo? ( x11-libs/cairo[X,glib,svg] )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ >=x11-libs/gtk+-3.20:3[introspection]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ -Db_pch=True # TODO this has to go
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}