summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <brahmajit.xyz@gmail.com>2022-06-23 19:33:54 +0530
committerSam James <sam@gentoo.org>2022-06-24 05:36:38 +0100
commitec465eaaa6c66f3d0ca20a65e3412ea9272c87d7 (patch)
tree38fdc7d9af7cc61e3a540a32786af6efba6754d0 /dev-libs/gjs
parentdev-python/scipy: Remove old (diff)
downloadgentoo-ec465eaaa6c66f3d0ca20a65e3412ea9272c87d7.tar.gz
gentoo-ec465eaaa6c66f3d0ca20a65e3412ea9272c87d7.tar.bz2
gentoo-ec465eaaa6c66f3d0ca20a65e3412ea9272c87d7.zip
dev-libs/gjs: Increase stack size on musl profile
On musl it required that either gjs, pixman or gnome-shell to be built with a larger stack otherwise librsvg fails to render a particular SVG, as a result we fail to get gdm or gnome-shell running (greeted with a fail whale screen). The bug has been reported to librsvg. For now this is just a temporary fix and will be removed later once an actual fix is found. Please refer to these bugs: https://gitlab.gnome.org/GNOME/librsvg/-/issues/686 https://gitlab.gnome.org/GNOME/librsvg/-/issues/874 Signed-off-by: brahmajit das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/26056 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/gjs')
-rw-r--r--dev-libs/gjs/gjs-1.72.0.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-libs/gjs/gjs-1.72.0.ebuild b/dev-libs/gjs/gjs-1.72.0.ebuild
index 842e4de4da6a..9e81950f35eb 100644
--- a/dev-libs/gjs/gjs-1.72.0.ebuild
+++ b/dev-libs/gjs/gjs-1.72.0.ebuild
@@ -34,6 +34,19 @@ BDEPEND="
src_configure() {
append-cppflags -DG_DISABLE_CAST_CHECKS
+ # On musl it required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. For now this is just
+ # a temporary fix and will be removed later once an actual fix is found.
+ #
+ # Please refer
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,--as-needed -Wl,-z,stack-size=2097152
+
# FIXME: add systemtap/dtrace support, like in glib:2
local emesonargs=(
$(meson_feature cairo)