summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/glib/glib-1.2.10-r6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/glib/glib-1.2.10-r6.ebuild')
-rw-r--r--dev-libs/glib/glib-1.2.10-r6.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-1.2.10-r6.ebuild b/dev-libs/glib/glib-1.2.10-r6.ebuild
new file mode 100644
index 000000000000..7233d4f7c3ef
--- /dev/null
+++ b/dev-libs/glib/glib-1.2.10-r6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GNOME_TARBALL_SUFFIX="gz"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 libtool flag-o-matic portability multilib-minimal
+
+DESCRIPTION="The GLib library of C routines"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/glib-1.2.10-r1-as-needed.patch.bz2
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="1"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+IUSE="hardened static-libs"
+
+DEPEND=""
+RDEPEND=""
+
+MULTILIB_CHOST_TOOLS=(/usr/bin/glib-config)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-automake.patch
+ epatch "${FILESDIR}"/${P}-m4.patch
+ epatch "${FILESDIR}"/${P}-configure-LANG.patch #133679
+
+ # Allow glib to build with gcc-3.4.x #47047
+ epatch "${FILESDIR}"/${P}-gcc34-fix.patch
+
+ # Fix for -Wl,--as-needed (bug #133818)
+ epatch "${DISTDIR}"/glib-1.2.10-r1-as-needed.patch.bz2
+
+ # build failure with automake-1.13
+ epatch "${FILESDIR}/${P}-automake-1.13.patch"
+
+ use ppc64 && use hardened && replace-flags -O[2-3] -O1
+ sed -i "/libglib_la_LDFLAGS/i libglib_la_LIBADD = $(dlopen_lib)" Makefile.am || die
+
+ rm -f acinclude.m4 #168198
+
+ mv configure.in configure.ac || die
+
+ eautoreconf
+ elibtoolize
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # Bug 48839: pam fails to build on ia64
+ # The problem is that it attempts to link a shared object against
+ # libglib.a; this library needs to be built with -fPIC. Since
+ # this package doesn't contain any significant binaries, build the
+ # whole thing with -fPIC (23 Apr 2004 agriffis)
+ append-flags -fPIC
+
+ ECONF_SOURCE="${S}" \
+ gnome2_src_configure \
+ --with-threads=posix \
+ --enable-debug=yes \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ gnome2_src_install
+
+ chmod 755 "${ED}"/usr/$(get_libdir)/libgmodule-1.2.so.* || die
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ dohtml -r docs
+}