summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-09-12 23:20:09 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-09-13 00:03:00 +0200
commitdd3f3f2d5eb63af2d3078fc7248bd06a551b6513 (patch)
tree7eed7a8f4546cc7a6a05c72fa5f38285f3a6afd2 /dev-libs/gmime
parentsys-block/thin-provisioning-tools: bump. (diff)
downloadgentoo-dd3f3f2d5eb63af2d3078fc7248bd06a551b6513.tar.gz
gentoo-dd3f3f2d5eb63af2d3078fc7248bd06a551b6513.tar.bz2
gentoo-dd3f3f2d5eb63af2d3078fc7248bd06a551b6513.zip
dev-libs/gmime: version bump 2.6.23 → 3.0.2
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-libs/gmime')
-rw-r--r--dev-libs/gmime/Manifest1
-rw-r--r--dev-libs/gmime/gmime-3.0.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-libs/gmime/Manifest b/dev-libs/gmime/Manifest
index 82052e762562..56d3878d5e2b 100644
--- a/dev-libs/gmime/Manifest
+++ b/dev-libs/gmime/Manifest
@@ -1 +1,2 @@
DIST gmime-2.6.23.tar.xz 5216588 SHA256 7149686a71ca42a1390869b6074815106b061aaeaaa8f2ef8c12c191d9a79f6a SHA512 2ff6718b7a555cd5b34848399f29c7d0aa5a15e1f3cb46e9258c499e874191ee00f41b737386805d3000bad34367d174a25c45d38ba90cba7902400e733afa14 WHIRLPOOL fe6d32ad46b6743cb7d8ee781d87724dc3ba4519cb98b95bb49ef55d257b28864dbf2fac1ada309dac363761e18f7bb8456933147d9d093ccf52aae4af694044
+DIST gmime-3.0.2.tar.xz 751944 SHA256 0deb460111ffa2ec672677da339b82dedeb28b258ccdb216daa21c81a9472fb2 SHA512 246f489c168ce7e04fab664b7e9ae7772ae52f0063fb0eac9153460d84fa5d9712457d81fbd1bdcdadb7e03007cf71ed3bad5287f1639214f54167427c9209ca WHIRLPOOL ff3c9ee2cdcff33cd6d2406ff72e925915f0901c92d3ba37a8ef5ee82d715c825e8337ecc68071daf5de67463653d91dd7b7a265ac6b6a883d3343e2fe51ca09
diff --git a/dev-libs/gmime/gmime-3.0.2.ebuild b/dev-libs/gmime/gmime-3.0.2.ebuild
new file mode 100644
index 000000000000..8b16292c8a03
--- /dev/null
+++ b/dev-libs/gmime/gmime-3.0.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit flag-o-matic gnome2 vala
+
+DESCRIPTION="Utilities for creating and parsing messages using MIME"
+HOMEPAGE="http://spruce.sourceforge.net/gmime/ https://developer.gnome.org/gmime/stable/"
+
+SLOT="3.0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="crypt doc idn static-libs test vala"
+
+RDEPEND="
+ >=dev-libs/glib-2.32.0:2
+ sys-libs/zlib
+ crypt? ( >=app-crypt/gpgme-1.8.0:1= )
+ idn? ( net-dns/libidn )
+ vala? (
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-1.30.0:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.8
+ virtual/libiconv
+ virtual/pkgconfig
+ doc? ( app-text/docbook-sgml-utils )
+ test? ( app-crypt/gnupg )
+"
+# gnupg is needed for tests if --enable-cryptography is enabled, which we do unconditionally
+
+src_prepare() {
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ if [[ ${CHOST} == *-solaris* ]]; then
+ # bug #???, why not use --with-libiconv
+ append-libs iconv
+ fi
+
+ gnome2_src_configure \
+ $(use_enable crypt crypto) \
+ $(use_enable static-libs static) \
+ $(use_enable vala) \
+ $(use_with idn libidn) \
+ $(usex doc "" DB2HTML=)
+}
+
+src_compile() {
+ gnome2_src_compile
+ if use doc; then
+ emake -C docs/tutorial html
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ docinto tutorial
+ dodoc -r docs/tutorial/html/
+ fi
+}