summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-11-02 09:08:38 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-02 09:33:40 +0100
commit740520b8f7146edfa3b62421ef6a4893c74cf960 (patch)
tree78ca0c2bca65258602e69b5cb0872bf3efbe4cdf /dev-libs/gobject-introspection
parentapp-admin/packagekit-base: PYTHON_USEDEP is inappropriate for gobject-introsp... (diff)
downloadgentoo-740520b8f7146edfa3b62421ef6a4893c74cf960.tar.gz
gentoo-740520b8f7146edfa3b62421ef6a4893c74cf960.tar.bz2
gentoo-740520b8f7146edfa3b62421ef6a4893c74cf960.zip
dev-libs/gobject-introspection: version bump 1.48.0 → 1.50.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/Manifest1
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-1.50.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection/Manifest b/dev-libs/gobject-introspection/Manifest
index b82167e286d8..e47bc6546df7 100644
--- a/dev-libs/gobject-introspection/Manifest
+++ b/dev-libs/gobject-introspection/Manifest
@@ -1,3 +1,4 @@
DIST gobject-introspection-1.44.0.tar.xz 1319168 SHA256 6f0c2c28aeaa37b5037acbf21558098c4f95029b666db755d3a12c2f1e1627ad SHA512 294bee6c935991620e6bfe4bd63d7b5c586079cdc9ac349dd5228f5822f86983a5a4518838c808c3fdd1152cb37f79db5ad8674245939ecad97459ce178f03e7 WHIRLPOOL fb032ae524bdbb011963c58e9d5d4a488fe89d95f2a353d0871176c26f1cb2f276743ec4bb97149f76135565965c173f149f163b78de47b994a5b4b32f3aa6aa
DIST gobject-introspection-1.46.0.tar.xz 1359436 SHA256 6658bd3c2b8813eb3e2511ee153238d09ace9d309e4574af27443d87423e4233 SHA512 2bdf988caadd6c4286ed90e35d26e1478d8ca627c8fb34f23d44473d0520f16b6082f0ee4f0acf44769bb5de2354119f2e28595ad8919668bebe5aec4c1ac210 WHIRLPOOL fb6c8570c41ebb06808e994811da2794ce3fe70ea1e5d50dcf2a4e72646efe8d49ce0ca176cecfc0bb6c9a3d7f47c13edd1c238b0e0e9649552793ff62145164
DIST gobject-introspection-1.48.0.tar.xz 1371308 SHA256 fa275aaccdbfc91ec0bc9a6fd0562051acdba731e7d584b64a277fec60e75877 SHA512 62b23fd94e19fd7f1557c8bdd045b4ec19b9a39c55ec4b4a75b817fc97f936c6fdbf89fa3ad09ffa707afb542b1c644b718ccaaefe194f681ad40c08d5c53975 WHIRLPOOL c284623cf5b0f6edc4d543fbbbc6b31b2e5ceb119b2fb4da1dbb052673ba79eeadba997f34fcd191f42e320cbd697733986d96ef3c4d8655765d7e586f7dbd54
+DIST gobject-introspection-1.50.0.tar.xz 1415700 SHA256 1c6597c666f543c70ef3d7c893ab052968afae620efdc080c36657f4226337c5 SHA512 cb108cf3d49743e1686fe4ae99f2360799bc8825ad97bf0b97e097b3f89e2771079593de0f497a9e5b9cff892f6fbf870834a6c4d13f11bcde99162e9388ecfa WHIRLPOOL 6147c2608c911020800471c30e6c754385efd61fe9f875bb7fad7d161e73cb857fa37c810e66bf0cf16a43aca1ecf6d2e46a6cde90800970f303c7721fdc5edb
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.50.0.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.50.0.ebuild
new file mode 100644
index 000000000000..223b2f9b305f
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-1.50.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-single-r1 toolchain-funcs versionator
+
+DESCRIPTION="Introspection system for GObject-based libraries"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+IUSE="cairo doctool test"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ test? ( cairo )
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# virtual/pkgconfig needed at runtime, bug #505408
+# We force glib and g-i to be in sync by this way as explained in bug #518424
+RDEPEND="
+ >=dev-libs/gobject-introspection-common-${PV}
+ >=dev-libs/glib-2.$(get_version_component_range 2):2
+ doctool? ( dev-python/mako )
+ virtual/libffi:=
+ virtual/pkgconfig
+ !<dev-lang/vala-0.20.0
+ ${PYTHON_DEPS}
+"
+# Wants real bison, not virtual/yacc
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.19
+ sys-devel/bison
+ sys-devel/flex
+"
+# PDEPEND to avoid circular dependencies, bug #391213
+PDEPEND="cairo? ( x11-libs/cairo[glib] )"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ if ! has_version "x11-libs/cairo[glib]"; then
+ # Bug #391213: enable cairo-gobject support even if it's not installed
+ # We only PDEPEND on cairo to avoid circular dependencies
+ export CAIRO_LIBS="-lcairo -lcairo-gobject"
+ export CAIRO_CFLAGS="-I${EPREFIX}/usr/include/cairo"
+ fi
+
+ # To prevent crosscompiling problems, bug #414105
+ gnome2_src_configure \
+ --disable-static \
+ CC="$(tc-getCC)" \
+ YACC="$(type -p yacc)" \
+ $(use_with cairo) \
+ $(use_enable doctool)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Prevent collision with gobject-introspection-common
+ rm -v "${ED}"usr/share/aclocal/introspection.m4 \
+ "${ED}"usr/share/gobject-introspection-1.0/Makefile.introspection || die
+ rmdir "${ED}"usr/share/aclocal || die
+}