summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-20 22:56:46 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-21 00:32:25 -0400
commitc6e966366b2e59e82613181cb7ee1f18f3ed725a (patch)
tree3bb9549e2f9790a815bcc6b1f865adb1ca1ade3c /dev-libs/gobject-introspection
parentdev-libs/gobject-introspection-common: Version bump to 1.68.0 (diff)
downloadgentoo-c6e966366b2e59e82613181cb7ee1f18f3ed725a.tar.gz
gentoo-c6e966366b2e59e82613181cb7ee1f18f3ed725a.tar.bz2
gentoo-c6e966366b2e59e82613181cb7ee1f18f3ed725a.zip
dev-libs/gobject-introspection: Version bump to 1.68.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/Manifest1
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-1.68.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection/Manifest b/dev-libs/gobject-introspection/Manifest
index 946bd1480d7d..fedb056064f7 100644
--- a/dev-libs/gobject-introspection/Manifest
+++ b/dev-libs/gobject-introspection/Manifest
@@ -1,3 +1,4 @@
DIST gobject-introspection-1.62.0.tar.xz 980732 BLAKE2B 96ecc98bea97b7cb24e2c0a0adb8158cfc8915ee8e3b980adf08ec3256d4d0f87bc92d33cce30f5b23c85c4b144d8da755e5313735091b27ff53fea45a80014e SHA512 b460a95fd7a323e9b0c9a45e680ebe98bbae7632abfa53b3e0b0ec050775cab17dde693314d6d4f8e93614c32b5587f8ce0b4a4c9ee9ba46c029ce029014e638
DIST gobject-introspection-1.64.1.tar.xz 1000280 BLAKE2B c0248831648f6f1849516f30facac9ecade4b4fdb9dce70f93f516364c08f93d0622e06376bd7895dd25c3f1fb5b0af533d6c60f1b2590848cc6781b81a584f4 SHA512 7610871f7ed5778ea9813062ed6465d131af58c00bdea1bb51dde7f98f459f44ae453eb6d0c5bdc6f7dcd92d639816f4e0773ccd5673cd065d22dabc6448647c
DIST gobject-introspection-1.66.1.tar.xz 1012784 BLAKE2B dd3faa70a482016c9d45b41a62eb1708b775979b92a466c45e70fa9f7679f3931467f5f41a30ecf2260afdd5759218f0afe68b82901587d7cf9267b1fe59d4e8 SHA512 ea1e20cd94ff8af3572f417f35e96648ffc3e94a91d4e4c81adf99bb0f408ac21ecf40990f9dbd5f2e0f4e83360286ca5db88dbc45bd59289596a324acf7df3d
+DIST gobject-introspection-1.68.0.tar.xz 1019732 BLAKE2B 2f99cc9cec5ea05f1a5fa4473d1ad424cc1f6b097075f798e89cf740519db180417a3f0de37afc8a0cf0771436a9d9f7d6193b69289dfb47ec077d33a7d27c91 SHA512 d2e64c119aa500b624a57baa2cebe9126ab100003d98b771f4fb51cf92748635de352997f702f40656f7c665f3dfedfbfa19912cc7a2d039d254555243bbc381
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.68.0.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.68.0.ebuild
new file mode 100644
index 000000000000..23eb08dfbd85
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-1.68.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="xml"
+inherit gnome.org meson python-single-r1 toolchain-funcs xdg
+
+DESCRIPTION="Introspection system for GObject-based libraries"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+IUSE="doctool gtk-doc test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# virtual/pkgconfig needed at runtime, bug #505408
+RDEPEND="
+ >=dev-libs/gobject-introspection-common-${PV}
+ >=dev-libs/glib-2.58.0:2
+ dev-libs/libffi:=
+ doctool? (
+ $(python_gen_cond_dep '
+ dev-python/mako[${PYTHON_MULTI_USEDEP}]
+ dev-python/markdown[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+# Wants real bison, not virtual/yacc
+DEPEND="${RDEPEND}
+ gtk-doc? ( >=dev-util/gtk-doc-1.19
+ app-text/docbook-xml-dtd:4.3
+ app-text/docbook-xml-dtd:4.5
+ )
+ sys-devel/bison
+ sys-devel/flex
+ test? (
+ x11-libs/cairo[glib]
+ $(python_gen_cond_dep '
+ dev-python/mako[${PYTHON_MULTI_USEDEP}]
+ dev-python/markdown[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test cairo)
+ $(meson_feature doctool)
+ #-Dglib_src_dir
+ $(meson_use gtk-doc gtk_doc)
+ #-Dcairo_libname
+ -Dpython="${EPYTHON}"
+ #-Dgir_dir_prefix
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"/usr/bin/
+ python_optimize "${ED}"/usr/$(get_libdir)/gobject-introspection/giscanner
+
+ # Prevent collision with gobject-introspection-common
+ rm -v "${ED}"/usr/share/aclocal/introspection.m4 \
+ "${ED}"/usr/share/gobject-introspection-1.0/Makefile.introspection || die
+ rmdir "${ED}"/usr/share/aclocal || die
+}