summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-02-17 17:52:20 +0200
committerMart Raudsepp <leio@gentoo.org>2019-02-17 18:04:54 +0200
commitcae385fb7636ff3fd9b2f735d46285a1ade1aa51 (patch)
tree062118632a79a7be01f5eab9912d697d38dcf1be /dev-libs/gom
parentmedia-gfx/graphite2: arm64 stable (bug #676956) (diff)
downloadgentoo-cae385fb7636ff3fd9b2f735d46285a1ade1aa51.tar.gz
gentoo-cae385fb7636ff3fd9b2f735d46285a1ade1aa51.tar.bz2
gentoo-cae385fb7636ff3fd9b2f735d46285a1ade1aa51.zip
dev-libs/gom: fix pkg-config file libdir
Broke consumers that use meson on 17.1 gentoo profiles Bug: https://bugs.gentoo.org/678190 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/gom')
-rw-r--r--dev-libs/gom/files/0.3.2-fix-pkgconfig.patch34
-rw-r--r--dev-libs/gom/gom-0.3.2-r1.ebuild (renamed from dev-libs/gom/gom-0.3.2.ebuild)6
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-libs/gom/files/0.3.2-fix-pkgconfig.patch b/dev-libs/gom/files/0.3.2-fix-pkgconfig.patch
new file mode 100644
index 000000000000..447c91421cc9
--- /dev/null
+++ b/dev-libs/gom/files/0.3.2-fix-pkgconfig.patch
@@ -0,0 +1,34 @@
+From 07c35149964c7258e52effa374d877a8f2f102e8 Mon Sep 17 00:00:00 2001
+From: Alexander Tsoy <alexander@tsoy.me>
+Date: Fri, 29 Jul 2016 03:18:03 +0300
+Subject: [PATCH] build: Replace hardcoded values in pkg-config file
+
+https://bugzilla.gnome.org/show_bug.cgi?id=769291
+---
+ data/gom-1.0.pc.in | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/data/gom-1.0.pc.in b/data/gom-1.0.pc.in
+index ce19de6..6edc841 100644
+--- a/data/gom-1.0.pc.in
++++ b/data/gom-1.0.pc.in
+@@ -1,11 +1,11 @@
+ prefix=@prefix@
+-exec_prefix=${prefix}
+-libdir=${exec_prefix}/lib
+-includedir=${exec_prefix}/include
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
+
+ Name: Gom
+ Description: GObject Data Mapper
+ Version: @VERSION@
+-Libs: -L${libdir} -lgom-1.0
+-Cflags: -I${includedir}/gom-1.0
++Libs: -L${libdir} -lgom-@GOM_API_VERSION@
++Cflags: -I${includedir}/gom-@GOM_API_VERSION@
+ Requires: gobject-2.0
+--
+2.17.0
+
diff --git a/dev-libs/gom/gom-0.3.2.ebuild b/dev-libs/gom/gom-0.3.2-r1.ebuild
index c69949bbf5ec..6589d8eb0a78 100644
--- a/dev-libs/gom/gom-0.3.2.ebuild
+++ b/dev-libs/gom/gom-0.3.2-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
GCONF_DEBUG="yes"
PYTHON_COMPAT=( python{3_4,3_5,3_6} )
-inherit gnome2 python-r1
+inherit epatch gnome2 python-r1
DESCRIPTION="GObject to SQLite object mapper library"
HOMEPAGE="https://wiki.gnome.org/Projects/Gom"
@@ -33,11 +33,13 @@ DEPEND="${RDEPEND}
"
# TODO: make gdk-pixbuf properly optional with USE=test
+
pkg_setup() {
use python && python_setup
}
src_prepare() {
+ epatch "${FILESDIR}"/${PV}-fix-pkgconfig.patch
gnome2_src_prepare
use python && python_copy_sources