summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@protonmail.com>2021-01-18 15:49:58 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-01 15:22:48 +0200
commita96f316d21e252d55ede38e13f6c646095ce7f91 (patch)
tree274c2735ee55992a43970beb7e5e02fe41db9588 /dev-libs/granite
parentdev-db/sqlcl-bin: removed old (diff)
downloadgentoo-a96f316d21e252d55ede38e13f6c646095ce7f91.tar.gz
gentoo-a96f316d21e252d55ede38e13f6c646095ce7f91.tar.bz2
gentoo-a96f316d21e252d55ede38e13f6c646095ce7f91.zip
dev-libs/granite: bump to 5.5.0
become maintainer; use vala with valadoc; simplify doc fixes; Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/19104 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/granite')
-rw-r--r--dev-libs/granite/Manifest1
-rw-r--r--dev-libs/granite/granite-5.2.5-r1.ebuild10
-rw-r--r--dev-libs/granite/granite-5.5.0.ebuild60
-rw-r--r--dev-libs/granite/metadata.xml25
4 files changed, 82 insertions, 14 deletions
diff --git a/dev-libs/granite/Manifest b/dev-libs/granite/Manifest
index 9be82cc60e4a..3d80e8f1c23a 100644
--- a/dev-libs/granite/Manifest
+++ b/dev-libs/granite/Manifest
@@ -1 +1,2 @@
DIST granite-5.2.5.tar.gz 392987 BLAKE2B 507c3b810b750257a66195b45842a7664eb544f86a8606124d30d277c03680296f1ace7a9233d6e094ad5ce3357564e13b61d946f8ed926ccf22a5d9b5e98648 SHA512 64a08293bc4b33d77206c7070b4e2002dd8e2da8a358e43074b681a9228790dcb342d3a705cfc0309a7e1e7f498a2a656e972c2fee085ba99fb5214e33758fc3
+DIST granite-5.5.0.tar.gz 421478 BLAKE2B 9b6e956fcacf5dba722dd999ed3de527a99bd305a2059bdc39fe00d767f0f855e8f3a4d0854fd441203bb5dfbb250669356f85b64e067ddc08e3d6dfc3fb389d SHA512 981ff9aa42146153d8450989513dd6b63cfb6cf2e52cf3e1d2d6380373b30754d9b357418810cfd14a53689a050f08337ca766b5b8496a4063106f78b377f139
diff --git a/dev-libs/granite/granite-5.2.5-r1.ebuild b/dev-libs/granite/granite-5.2.5-r1.ebuild
index dc1cb86a0666..56f8f0eaaf6f 100644
--- a/dev-libs/granite/granite-5.2.5-r1.ebuild
+++ b/dev-libs/granite/granite-5.2.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,21 +15,21 @@ SRC_URI="https://github.com/elementary/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE="doc +introspection test"
+IUSE="doc test"
RESTRICT="!test? ( test )"
BDEPEND="
$(vala_depend)
virtual/pkgconfig
doc? (
- dev-lang/vala[valadoc]
+ >=dev-lang/vala-0.40.20[valadoc]
dev-util/gtk-doc
)
"
DEPEND="
>=dev-libs/glib-2.50:2
- dev-libs/libgee:0.8[introspection=]
- >=x11-libs/gtk+-3.22:3[introspection=]
+ dev-libs/libgee:0.8[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
"
RDEPEND="${DEPEND}"
diff --git a/dev-libs/granite/granite-5.5.0.ebuild b/dev-libs/granite/granite-5.5.0.ebuild
new file mode 100644
index 000000000000..68db9bcac893
--- /dev/null
+++ b/dev-libs/granite/granite-5.5.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VALA_MIN_API_VERSION=0.40
+BUILD_DIR="${WORKDIR}/${P}-build"
+
+inherit meson vala xdg
+
+DESCRIPTION="Elementary OS library that extends GTK+"
+HOMEPAGE="https://github.com/elementary/granite"
+SRC_URI="https://github.com/elementary/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+BDEPEND="
+ $(vala_depend)
+ virtual/pkgconfig
+ doc? (
+ >=dev-lang/vala-0.40.20[valadoc]
+ dev-util/gtk-doc
+ )
+"
+DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection]
+ dev-libs/libgee:0.8[introspection]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ vala_src_prepare
+
+ # Fix docs
+ sed -i "s/find_program('valadoc')/find_program('valadoc-$(vala_best_api_version)')/g" doc/meson.build \
+ || die "Failed to replace valadoc"
+ find lib/Widgets -type f -name "*.vala" -exec sed -ie "s@{{../doc@{{${BUILD_DIR}/doc@g" {} \; \
+ || die "Failed to fix docs"
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc documentation)
+ )
+ meson_src_configure
+
+ if use doc; then
+ cp -r ./doc/images "${BUILD_DIR}/doc/" || die "Failed to copy doc images"
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}/doc/granite/html/." )
+ meson_src_install
+}
diff --git a/dev-libs/granite/metadata.xml b/dev-libs/granite/metadata.xml
index 7ba599558211..eb3302b9001c 100644
--- a/dev-libs/granite/metadata.xml
+++ b/dev-libs/granite/metadata.xml
@@ -1,13 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription lang="en">
- Granite is a companion library for GTK+ and GLib. Among other things,
- it provides complex widgets and convenience functions designed for
- use in apps built for elementary OS.
- </longdescription>
- <upstream>
- <remote-id type="github">elementary/granite</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>xgqt@protonmail.com</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Granite is a companion library for GTK+ and GLib.
+ Among other things, it provides complex widgets and convenience
+ functions designed for use in apps built for elementary OS.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">elementary/granite</remote-id>
+ </upstream>
</pkgmetadata>