summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-23 19:10:27 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-23 19:10:48 +0200
commit529ac465f12bf9ead54425ac142154d86389ae2a (patch)
tree84b9ae2861e4a08c979904ff097b606c9c6a8018 /dev-libs/hiredis/hiredis-0.14.1.ebuild
parentxfce-extra/xfce4-whiskermenu-plugin: Bump to 2.4.6 (diff)
downloadgentoo-529ac465f12bf9ead54425ac142154d86389ae2a.tar.gz
gentoo-529ac465f12bf9ead54425ac142154d86389ae2a.tar.bz2
gentoo-529ac465f12bf9ead54425ac142154d86389ae2a.zip
dev-libs/hiredis: don't call AR directly
While here, update other vars we pass to Makefile. Closes: https://bugs.gentoo.org/723704 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/hiredis/hiredis-0.14.1.ebuild')
-rw-r--r--dev-libs/hiredis/hiredis-0.14.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-libs/hiredis/hiredis-0.14.1.ebuild b/dev-libs/hiredis/hiredis-0.14.1.ebuild
index 9028b420d2de..b0bf2fbfaedb 100644
--- a/dev-libs/hiredis/hiredis-0.14.1.ebuild
+++ b/dev-libs/hiredis/hiredis-0.14.1.ebuild
@@ -18,7 +18,10 @@ RESTRICT="!test? ( test )"
DEPEND="test? ( dev-db/redis )"
src_prepare() {
- local PATCHES=( "${FILESDIR}/${PN}-0.13.3-disable-network-tests.patch" )
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-0.13.3-disable-network-tests.patch
+ "${FILESDIR}"/${PN}-0.14.1-honor-AR.patch
+ )
default
# use GNU ld syntax on Solaris
@@ -31,9 +34,8 @@ _build() {
CC="$(tc-getCC)" \
PREFIX="${EPREFIX}/usr" \
LIBRARY_PATH="$(get_libdir)" \
- ARCH= \
- DEBUG= \
- OPTIMIZATION="${CPPFLAGS}" \
+ DEBUG_FLAGS= \
+ OPTIMIZATION= \
"$@"
}