summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-03-05 16:37:05 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-03-08 23:48:26 +0100
commit9c3bfee419467b417400fe45921205b502e17d68 (patch)
tree34bb3aee51c2ac119b69f685790cf51de1c25c7f /dev-libs/http-fetcher
parentnet-wireless/wireless-regdb: bumpity bump (diff)
downloadgentoo-9c3bfee419467b417400fe45921205b502e17d68.tar.gz
gentoo-9c3bfee419467b417400fe45921205b502e17d68.tar.bz2
gentoo-9c3bfee419467b417400fe45921205b502e17d68.zip
dev-libs/http-fetcher: EAPI 6 bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/http-fetcher')
-rw-r--r--dev-libs/http-fetcher/http-fetcher-1.1.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/http-fetcher/http-fetcher-1.1.0-r1.ebuild b/dev-libs/http-fetcher/http-fetcher-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..82fa74245a70
--- /dev/null
+++ b/dev-libs/http-fetcher/http-fetcher-1.1.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="Library for downloading files via HTTP using the GET method"
+HOMEPAGE="http://http-fetcher.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="debug"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-strict \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ dodoc -r docs/html/*.html docs/index.html README ChangeLog CREDITS INSTALL
+}