summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/hyperleveldb/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/hyperleveldb/files')
-rw-r--r--dev-libs/hyperleveldb/files/snappy.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/hyperleveldb/files/snappy.patch b/dev-libs/hyperleveldb/files/snappy.patch
new file mode 100644
index 000000000000..f926e3f6a38c
--- /dev/null
+++ b/dev-libs/hyperleveldb/files/snappy.patch
@@ -0,0 +1,31 @@
+--- Makefile.am 2014-07-29 14:44:37.851568232 +0800
++++ Makefile.am.new 2014-07-29 14:44:54.687855718 +0800
+@@ -196,7 +196,7 @@
+ TESTS = $(check_PROGRAMS)
+
+ benchmark_SOURCES = benchmark.cc
+-benchmark_LDADD = libhyperleveldb.la -lpthread -le -lpopt -lygor
++benchmark_LDADD = libhyperleveldb.la -lpthread -le -lpopt -lygor -lsnappy
+ benchmark_LDFLAGS = -no-install
+
+ db_bench_SOURCES = db/db_bench.cc $(TESTUTIL)
+
+@@ -200,7 +200,7 @@
+ benchmark_LDFLAGS = -no-install
+
+ db_bench_SOURCES = db/db_bench.cc $(TESTUTIL)
+-db_bench_LDADD = libhyperleveldb.la -lpthread
++db_bench_LDADD = libhyperleveldb.la -lpthread -lsnappy
+
+ db_bench_sqlite3_SOURCES = doc/bench/db_bench_sqlite3.cc $(TESTUTIL)
+ db_bench_sqlite3_LDADD = -lsqlite3
+@@ -215,7 +215,7 @@
+ leveldb_dump_all_LDADD = libhyperleveldb.la -lpthread
+
+ leveldb_verify_SOURCES = leveldb-verify.cc
+-leveldb_verify_LDADD = libhyperleveldb.la -lpthread
++leveldb_verify_LDADD = libhyperleveldb.la -lpthread -lsnappy
+
+ autocompact_test_SOURCES = db/autocompact_test.cc $(TESTHARNESS)
+ autocompact_test_LDADD = libhyperleveldb.la -lpthread
+