summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGino <onigino@protonmail.com>2018-11-11 23:46:12 -0800
committerMichał Górny <mgorny@gentoo.org>2019-07-14 14:41:57 +0200
commitcd8da3ea5bd0c4668e7b9f6d85f9a19dc89d21f2 (patch)
tree30533ee9df86c9bf6e54ed83415d4c3d49f5b794 /dev-libs/hyphen
parentapp-dicts/myspell-en: Add back en-US hyphen file (diff)
downloadgentoo-cd8da3ea5bd0c4668e7b9f6d85f9a19dc89d21f2.tar.gz
gentoo-cd8da3ea5bd0c4668e7b9f6d85f9a19dc89d21f2.tar.bz2
gentoo-cd8da3ea5bd0c4668e7b9f6d85f9a19dc89d21f2.zip
dev-libs/hyphen-2.8.8: Do not install hyph_en_US.dic file
Bug: https://bugs.gentoo.org/589942 Signed-off-by: Gino McCarty <onigino@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/11820 [mgorny: corrected not to remove docs, fixed EAPI 7] Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/hyphen')
-rw-r--r--dev-libs/hyphen/hyphen-2.8.8-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/hyphen/hyphen-2.8.8-r1.ebuild b/dev-libs/hyphen/hyphen-2.8.8-r1.ebuild
new file mode 100644
index 000000000000..185c29e311bc
--- /dev/null
+++ b/dev-libs/hyphen/hyphen-2.8.8-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="ALTLinux hyphenation library"
+HOMEPAGE="http://hunspell.github.io/"
+SRC_URI="mirror://sourceforge/hunspell/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="app-text/hunspell"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README{,.nonstandard,.hyphen,.compound} THANKS TODO )
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ rm -r "${ED}"/usr/share/hyphen || die
+ rm "${ED}"/usr/lib*/libhyphen.la || die
+}