summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-12-12 03:58:47 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-12-12 04:02:01 +0100
commit69bbf4d7663ae40e8df4068382510b805cd6cbfc (patch)
tree14887f3a70b798590c872793f10558574288fc2b /dev-libs/inih/inih-52.ebuild
parentdev-perl/Alien-Build: Cleanup old 2.2{8,9}0.0 (diff)
downloadgentoo-69bbf4d7663ae40e8df4068382510b805cd6cbfc.tar.gz
gentoo-69bbf4d7663ae40e8df4068382510b805cd6cbfc.tar.bz2
gentoo-69bbf4d7663ae40e8df4068382510b805cd6cbfc.zip
dev-libs/inih: Bump to version 52
Ebuild cleanup and corrections. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/inih/inih-52.ebuild')
-rw-r--r--dev-libs/inih/inih-52.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/inih/inih-52.ebuild b/dev-libs/inih/inih-52.ebuild
new file mode 100644
index 000000000000..dbf1c3a62e42
--- /dev/null
+++ b/dev-libs/inih/inih-52.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+
+S="${WORKDIR}/inih-r${PV}"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_install_all() {
+ local DOCS=(
+ LICENSE.txt
+ README.md
+ )
+ einstalldocs
+}