summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-14 05:15:00 +0100
committerSam James <sam@gentoo.org>2022-07-14 05:16:29 +0100
commiteb3f16807d9016715bdc9218a0f4290d4fe3d7be (patch)
treea180ea963fec2933aaace34852b525f67d78def4 /dev-libs/inih
parentmedia-libs/babl: 0.1.92-r1. Fix universal_nonlinear_rgb_u8_converter_sse2 (diff)
downloadgentoo-eb3f16807d9016715bdc9218a0f4290d4fe3d7be.tar.gz
gentoo-eb3f16807d9016715bdc9218a0f4290d4fe3d7be.tar.bz2
gentoo-eb3f16807d9016715bdc9218a0f4290d4fe3d7be.zip
dev-libs/inih: add 56
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/inih')
-rw-r--r--dev-libs/inih/Manifest1
-rw-r--r--dev-libs/inih/inih-56.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/inih/Manifest b/dev-libs/inih/Manifest
index 5cbed445c5b5..82898e33779a 100644
--- a/dev-libs/inih/Manifest
+++ b/dev-libs/inih/Manifest
@@ -1 +1,2 @@
DIST inih-55.tar.gz 18219 BLAKE2B 28b5e04e54e31b3e0392b44799a2c2e75c1fe00527491a857480b7e960302f2438d29652b131dae5147487c863d93f577b67aeff3ab5f863546d3661628d8236 SHA512 bcbef361a4400da017dbed811ad21672b58512d2b2b537cc0058cdeca709dd0d5a9def4045ce1c1972873c3d3d35182123337e4388676f6f0d16e8dbff967b0f
+DIST inih-56.tar.gz 18458 BLAKE2B 51935959a9eb4e393b17302f0932a232963883680f10d404c63d5f2ebbd3bf0b740f44edfa1b2541d0e130016eb853ebedf68a1c40797f658496e2a8c966af3d SHA512 ff3e0910990f73e5b21fddc84737ab346279f201c86c7ad864c6cad9de5bde57c3e0a433b9b8f3585b7d86feaae2ea074185f92891dcadc98c274c1c0745d2d2
diff --git a/dev-libs/inih/inih-56.ebuild b/dev-libs/inih/inih-56.ebuild
new file mode 100644
index 000000000000..711dd5e438b6
--- /dev/null
+++ b/dev-libs/inih/inih-56.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Tests not wired up to meson and don't seem to be intended for downstream use yet
+# e.g. hardcoding gcc, just a shell script
+
+inherit meson-multilib
+
+DESCRIPTION="inih (INI not invented here) simple .INI file parser"
+HOMEPAGE="https://github.com/benhoyt/inih"
+
+SRC_URI="https://github.com/benhoyt/inih/archive/r${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+S="${WORKDIR}/inih-r${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+
+DOCS=( README.md )
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=shared
+ -Ddistro_install=true
+ -Dwith_INIReader=true
+ )
+
+ meson_src_configure
+}