summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2017-05-17 00:41:28 +0200
committerMaciej Mrozowski <reavertm@gentoo.org>2017-05-17 00:41:43 +0200
commit2d646da0a7439af0ff0af39d144195daafba3012 (patch)
treed74699631be1c31c2c13becf03414f8442154a5c /dev-libs/injeqt/injeqt-1.2.0.ebuild
parentapp-emulation/wine-staging: Bump to 2.8 (diff)
downloadgentoo-2d646da0a7439af0ff0af39d144195daafba3012.tar.gz
gentoo-2d646da0a7439af0ff0af39d144195daafba3012.tar.bz2
gentoo-2d646da0a7439af0ff0af39d144195daafba3012.zip
dev-libs/injeqt: Version bump 1.2.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-libs/injeqt/injeqt-1.2.0.ebuild')
-rw-r--r--dev-libs/injeqt/injeqt-1.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/injeqt/injeqt-1.2.0.ebuild b/dev-libs/injeqt/injeqt-1.2.0.ebuild
new file mode 100644
index 000000000000..6b98e1bd2372
--- /dev/null
+++ b/dev-libs/injeqt/injeqt-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Dependency injection framework for Qt5"
+HOMEPAGE="https://github.com/vogel/injeqt"
+SRC_URI="https://github.com/vogel/injeqt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-qt/qtcore-5.4.2:5
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qttest-5.4.2:5 )
+"
+
+# https://github.com/vogel/injeqt/issues/18
+RESTRICT=test
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_EXAMPLES=ON
+ -DDISABLE_TESTS=$(usex !test)
+ )
+ cmake-utils_src_configure
+}