summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-07-02 16:49:19 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-07-02 16:58:41 +0200
commit3ea18399ea50480dee355d2d67e6206f3c91a1ef (patch)
tree69308840652c8b4778a94177ada974223cf2d821 /dev-libs/intel-compute-runtime
parentdev-lua/luarocks: add 3.9.1 (diff)
downloadgentoo-3ea18399ea50480dee355d2d67e6206f3c91a1ef.tar.gz
gentoo-3ea18399ea50480dee355d2d67e6206f3c91a1ef.tar.bz2
gentoo-3ea18399ea50480dee355d2d67e6206f3c91a1ef.zip
dev-libs/intel-compute-runtime: add 22.26.23599
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.26.23599.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index bd94a968c7aa..5b1ce925e8c0 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -3,3 +3,4 @@ DIST intel-compute-runtime-22.22.23355.tar.gz 5498680 BLAKE2B 81368ca9a5151305a5
DIST intel-compute-runtime-22.23.23405.tar.gz 5515173 BLAKE2B eafb5a4ed8a221bc5290576a137f371f2f9d3cebbe1e689f3d1ce41f9430a5242d82ae78799f523f29685c3a731570e4a6766f804faa0f6bb7bae365cb5d6573 SHA512 38ffadd9130717acb0e8d6492b2bb4d8d5c962b151784a92c85d6249cbab1014dcd418bf5110eccc1640334c1ab0d171b7028d2f0d95d606733b42a319bf2f0b
DIST intel-compute-runtime-22.24.23453.tar.gz 5521386 BLAKE2B c025539c0d2a0ac492ddc5893c0d077523bbc0c0e1dcdb3d086ff381b36f26d0a7b24aecb0ba04e915e443eafecbaf171ef54fc0c455e57b0ae622ef164f4056 SHA512 fb57348ef4cad48b7d09bf8db64a874a63bdbbd586323c25b7c9cf7461bfd62c1cd061c4b989c52466e5d364fde9dec2335bf7e244baadd573888ba904ba867c
DIST intel-compute-runtime-22.25.23529.tar.gz 5542277 BLAKE2B da718987fd3f3239b6cfc60914f02cc67b7174cb92f3a12e5d8f78b39631892b1c69368eb89590c3a7dfc9e930eb8254ec33c43028073cffac06bd3f718164bb SHA512 5ad80357a27cba76b95099ce5a0edc5271d7328769d6e84039fa94f94be99f02cf4890ee05702db18e28beba6fadea46aa2f0eb236ed8c27cb95bee075f2f6d6
+DIST intel-compute-runtime-22.26.23599.tar.gz 5574368 BLAKE2B 6302ced3e75d7d31a55c20e0c08f915fc2d3df149a843115ce925c62b50e2c9b47fc61ea48ad45a52967703f3d9e31ff23cd4e61d1666e5cf072d7c84c0ef416 SHA512 1ce2b0e9d3886ab51636265c7e1a91bbe817e27995d8e2d96fc4b67633c89f11232005f18f81a462f76fa67d9298fce51a335b9c4545d8b461019cd9e487b4dc
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.26.23599.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.26.23599.ebuild
new file mode 100644
index 000000000000..077189e165cf
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.26.23599.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND=">=media-libs/gmmlib-22.0.2:="
+
+DEPEND="
+ ${DEPEND}
+ dev-libs/intel-metrics-library:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.11061-r1
+ >=dev-util/intel-graphics-system-controller-0.2.4:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.7.15 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch" )
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}