summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-09 16:46:11 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-09 16:54:49 +0200
commit957edc65a80af68b3a276c99d6a16819a939a188 (patch)
treeaae1ed3ac0ae97d38e03433f63f9d3a5442f571d /dev-libs/intel-compute-runtime
parentmedia-libs/gmmlib: drop 22.0.2 (diff)
downloadgentoo-957edc65a80af68b3a276c99d6a16819a939a188.tar.gz
gentoo-957edc65a80af68b3a276c99d6a16819a939a188.tar.bz2
gentoo-957edc65a80af68b3a276c99d6a16819a939a188.zip
dev-libs/intel-compute-runtime: add 22.14.22890
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.14.22890.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 2681a6b7bb85..cdcc9805f808 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,3 +1,4 @@
DIST intel-compute-runtime-21.46.21636.tar.gz 4878855 BLAKE2B 0ada296b36567038b2abeba50c2dae6604981f00cdfc0d5d9d197c793534c887fa1d321ced34b37cf6760bdc9e2b8769cdc24fe3884036b78b983660c90b1ee7 SHA512 a63436d049737b955f0e23bbfc78684f665f3d1a668120e803165839792144154f3f42a52c6533611711592ba6e41408d81196a61e318746b1dae1392d1d29ac
DIST intel-compute-runtime-22.12.22749.tar.gz 5234659 BLAKE2B 162c4781561a131af51779108817d2a39ea9676e3772a776603c1e7670b03eddd800593a6e9d77d852476b2401582f3ff87c8b9582b5fa0769ab5ec48be6ba70 SHA512 16e4c76a38284d4e1470977845d338dc05195351ac53d63528e93f1990b81d03a8f1a31c53c665fb8e19b5dc9f4ce38ff392ee1158769780de7a7cb83b2b361b
DIST intel-compute-runtime-22.13.22789.tar.gz 5252140 BLAKE2B 81fe85e75b1f6257771950dd2716e48f8db61dbe62f747c13ed00be7385c9e6a2f2cd2a5d50cf4253962d13bd1fdb4449a5e646fe3a8b10af228f746b9880210 SHA512 e4d22d8f73463300424b2df9a9634f0b5ac341131de33e57d46ffd52ce0b3fbdbf62cf591876d2143ca14caeba42ec95f5aef201eb9895e5d36b2279b15e661c
+DIST intel-compute-runtime-22.14.22890.tar.gz 5290076 BLAKE2B 9a6ec8ed142a183d270006726d34492adea989bc2db9eff53046f4c247f7d5089e4cbb6448513b54eeaf7079f990f9a3b6d31cca53459bc2fcd1ced5d2b1bea1 SHA512 78c195832a0f55ff0bf64519234a5f70f1459263000804db1cc73a72c4c07e12c540a9fa0a574bf382713deb132be50b6e6eb7b4abfd264f707889bf02fc1af7
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.14.22890.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.14.22890.ebuild
new file mode 100644
index 000000000000..a58424820a2a
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.14.22890.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND=">=media-libs/gmmlib-22.0.2:="
+
+DEPEND="
+ ${DEPEND}
+ dev-libs/intel-metrics-library
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.10713
+ >=dev-util/intel-graphics-system-controller-0.2.4
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.7.15 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+
+ -Wno-dev
+ )
+
+ cmake_src_configure
+}