summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-07-19 21:18:55 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-07-19 21:38:04 +0200
commitce205f1b7b56779ffa2ee668ef087f1ff62e317c (patch)
treefd07b94d821dca19443f7b65886c84bc4401473d /dev-libs/intel-compute-runtime
parentdev-util/intel-graphics-compiler: switch to LLVM14 (diff)
downloadgentoo-ce205f1b7b56779ffa2ee668ef087f1ff62e317c.tar.gz
gentoo-ce205f1b7b56779ffa2ee668ef087f1ff62e317c.tar.bz2
gentoo-ce205f1b7b56779ffa2ee668ef087f1ff62e317c.zip
dev-libs/intel-compute-runtime: add 22.28.23726
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.28.23726.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index c94abd48143d..b7ea013beef7 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -3,3 +3,4 @@ DIST intel-compute-runtime-22.24.23453.tar.gz 5521386 BLAKE2B c025539c0d2a0ac492
DIST intel-compute-runtime-22.25.23529.tar.gz 5542277 BLAKE2B da718987fd3f3239b6cfc60914f02cc67b7174cb92f3a12e5d8f78b39631892b1c69368eb89590c3a7dfc9e930eb8254ec33c43028073cffac06bd3f718164bb SHA512 5ad80357a27cba76b95099ce5a0edc5271d7328769d6e84039fa94f94be99f02cf4890ee05702db18e28beba6fadea46aa2f0eb236ed8c27cb95bee075f2f6d6
DIST intel-compute-runtime-22.26.23599.tar.gz 5574368 BLAKE2B 6302ced3e75d7d31a55c20e0c08f915fc2d3df149a843115ce925c62b50e2c9b47fc61ea48ad45a52967703f3d9e31ff23cd4e61d1666e5cf072d7c84c0ef416 SHA512 1ce2b0e9d3886ab51636265c7e1a91bbe817e27995d8e2d96fc4b67633c89f11232005f18f81a462f76fa67d9298fce51a335b9c4545d8b461019cd9e487b4dc
DIST intel-compute-runtime-22.27.23681.tar.gz 5593740 BLAKE2B 5d627623e7b0ec89aacb5dfee7442803254c233382a2b242f0f856d51256a60d614e6a3d88ec5c0d494ad25211adb5d75a13b5ff86739795e46aa50e7a9686e4 SHA512 1269126ff447f7c0e1ec9e33ef5245476afe44812a2b6ded86f6219ae61c74bf862a152a740684638b12cdcffce454af3a3be5b4b16c3b7f9c0e7b660b73701a
+DIST intel-compute-runtime-22.28.23726.tar.gz 5609087 BLAKE2B ec5b70090e58b08d63f006034d4326426f4caf42b681e32027da79876d019875540ed52cf048fe9919d54bcbac5911bac6ea8a228b8020b9e56d5a61bd1c3c2b SHA512 5e59c678a146eb995e6bcfcedb96c812e40d4561cd4725740742691fc79fd597f4c31659b08763376263ff6100a0f7960f4d5f05a35ff97bed2dc870df189c48
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.28.23726.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.28.23726.ebuild
new file mode 100644
index 000000000000..178084ec239d
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.28.23726.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND=">=media-libs/gmmlib-22.1.7:="
+
+DEPEND="
+ ${DEPEND}
+ >=dev-libs/intel-metrics-library-0_pre20220526:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.11485-r1
+ >=dev-util/intel-graphics-system-controller-0.8.0:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.8.1:= )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch" )
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}