summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-10-01 22:52:30 +0100
committerMarek Szuba <marecki@gentoo.org>2019-10-01 22:54:13 +0100
commit6ec04b7fb19926278cc2d7d3ae5d67aa889e380e (patch)
tree9bcdb93848994fb24c970e4319921e42d1025814 /dev-libs/intel-neo/intel-neo-19.38.14237.ebuild
parentdev-util/intel-graphics-compiler: bump to 1.0.11 (diff)
downloadgentoo-6ec04b7fb19926278cc2d7d3ae5d67aa889e380e.tar.gz
gentoo-6ec04b7fb19926278cc2d7d3ae5d67aa889e380e.tar.bz2
gentoo-6ec04b7fb19926278cc2d7d3ae5d67aa889e380e.zip
dev-libs/intel-neo: bump to 19.38.14237
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-libs/intel-neo/intel-neo-19.38.14237.ebuild')
-rw-r--r--dev-libs/intel-neo/intel-neo-19.38.14237.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/intel-neo/intel-neo-19.38.14237.ebuild b/dev-libs/intel-neo/intel-neo-19.38.14237.ebuild
new file mode 100644
index 000000000000..843898c5f91f
--- /dev/null
+++ b/dev-libs/intel-neo/intel-neo-19.38.14237.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+MY_PN="compute-runtime"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for OpenCL, for Gen8 (Broadwell) and beyond"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="vaapi"
+
+BDEPEND="virtual/pkgconfig"
+COMMON="dev-libs/ocl-icd
+ >=dev-util/intel-graphics-compiler-1.0.11
+ >=media-libs/gmmlib-19.2.4
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ >=x11-libs/libva-2.0.0
+ )"
+DEPEND="${COMMON}
+ media-libs/mesa" # for Khronos OpenGL headers
+RDEPEND="${COMMON}"
+
+DOCS=(
+ README.md
+ documentation/FAQ.md
+ documentation/LIMITATIONS.md
+)
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DKHRONOS_GL_HEADERS_DIR="${EPREFIX}/usr/include"
+ -DDISABLE_LIBVA=$(usex vaapi "OFF" "ON")
+ # If enabled, tests are automatically run during the compile phase
+ # - and we cannot run them because they require permissions to access
+ # the hardware.
+ -DSKIP_UNIT_TESTS=ON
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ "${ROOT}"/usr/bin/eselect opencl set --use-old ocl-icd
+}