summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-09-21 20:04:03 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-09-21 20:25:49 +0200
commit13b64f3e9a309d2fde4b9667cd70311b2351853c (patch)
tree717d3b393e9310743aea73d669601243bf2dd240 /dev-libs/intel-neo/intel-neo-20.16.16582.ebuild
parentsys-kernel/gentoo-sources: Clean-up of 5.14.X series (diff)
downloadgentoo-13b64f3e9a309d2fde4b9667cd70311b2351853c.tar.gz
gentoo-13b64f3e9a309d2fde4b9667cd70311b2351853c.tar.bz2
gentoo-13b64f3e9a309d2fde4b9667cd70311b2351853c.zip
dev-libs/intel-neo: drop old versions
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/intel-neo/intel-neo-20.16.16582.ebuild')
-rw-r--r--dev-libs/intel-neo/intel-neo-20.16.16582.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-libs/intel-neo/intel-neo-20.16.16582.ebuild b/dev-libs/intel-neo/intel-neo-20.16.16582.ebuild
deleted file mode 100644
index 9c033bd1c114..000000000000
--- a/dev-libs/intel-neo/intel-neo-20.16.16582.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-MY_PN="compute-runtime"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Intel Graphics Compute Runtime for L0 and OpenCL, for Broadwell and beyond"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="l0 vaapi"
-
-BDEPEND="virtual/pkgconfig"
-COMMON=">=virtual/opencl-3
- >=dev-util/intel-graphics-compiler-1.0.3826
- >=media-libs/gmmlib-20.1.1
- l0? ( <dev-libs/level-zero-1.0.0 )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- x11-libs/libva
- )"
-DEPEND="${COMMON}
- media-libs/mesa" # for Khronos OpenGL headers
-RDEPEND="${COMMON}"
-
-DOCS=(
- README.md
- FAQ.md
-)
-
-S="${WORKDIR}"/${MY_P}
-
-src_configure() {
- local mycmakeargs=(
- -DKHRONOS_GL_HEADERS_DIR="${EPREFIX}/usr/include"
- -DBUILD_WITH_L0=$(usex l0)
- -DDISABLE_LIBVA=$(usex vaapi "no" "yes")
- # If enabled, tests are automatically run during the compile phase
- # - and we cannot run them because they require permissions to access
- # the hardware.
- -DSKIP_UNIT_TESTS=ON
- )
- cmake_src_configure
-}