summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Zero <zero-one@zer0-one.net>2020-07-06 22:58:43 -0700
committerJoonas Niilola <juippis@gentoo.org>2020-07-07 16:56:32 +0300
commit0e969fee81819f12d277177548d434ba697af02c (patch)
tree91ece888b0745ed2a3121c38bf664d3c7cfa6c9b /dev-libs/jansson/jansson-2.13.1.ebuild
parentnet-misc/hylafaxplus: RedundantLongDescription (diff)
downloadgentoo-0e969fee81819f12d277177548d434ba697af02c.tar.gz
gentoo-0e969fee81819f12d277177548d434ba697af02c.tar.bz2
gentoo-0e969fee81819f12d277177548d434ba697af02c.zip
dev-libs/jansson: Version bump to 2.13.1
Signed-off-by: David Zero <zero-one@zer0-one.net> Closes: https://github.com/gentoo/gentoo/pull/16524 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/jansson/jansson-2.13.1.ebuild')
-rw-r--r--dev-libs/jansson/jansson-2.13.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/jansson/jansson-2.13.1.ebuild b/dev-libs/jansson/jansson-2.13.1.ebuild
new file mode 100644
index 000000000000..d8f772c1fc15
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.13.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="https://www.digip.org/jansson/"
+SRC_URI="https://www.digip.org/jansson/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc static-libs"
+
+BDEPEND="doc? ( <dev-python/sphinx-3.0.0 )"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ emake html
+ HTML_DOCS=( "${BUILD_DIR}"/doc/_build/html/. )
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}