summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-08-25 14:52:53 +0200
committerPacho Ramos <pacho@gentoo.org>2021-08-25 14:52:53 +0200
commit692a0e4c5449ce34ede9c7cf98bffb331041ce90 (patch)
treee0d5e275f1dd36384a5c84c31302312e9c7be4ef /dev-libs/json-glib
parentmedia-gfx/gthumb: Bump to 3.10.4 (diff)
downloadgentoo-692a0e4c5449ce34ede9c7cf98bffb331041ce90.tar.gz
gentoo-692a0e4c5449ce34ede9c7cf98bffb331041ce90.tar.bz2
gentoo-692a0e4c5449ce34ede9c7cf98bffb331041ce90.zip
dev-libs/json-glib: Bump to 1.6.6
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-libs/json-glib')
-rw-r--r--dev-libs/json-glib/Manifest1
-rw-r--r--dev-libs/json-glib/json-glib-1.6.6.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/json-glib/Manifest b/dev-libs/json-glib/Manifest
index c4f61cf35aa7..97c68d2bf80b 100644
--- a/dev-libs/json-glib/Manifest
+++ b/dev-libs/json-glib/Manifest
@@ -1 +1,2 @@
DIST json-glib-1.6.2.tar.xz 170260 BLAKE2B 8039661c92c0f8d79189fcc2d01fea0615ce13190526960178f727255c8ca5e1cd2f06079782b3513aa6686fe402d45b10ead798af196523552be73912cb54e9 SHA512 8412390a639d368ed11181621739f43bc4900143ac062c3824c7140abec58ca2b09773a415034f03896a4ff63aa3414b492997da532848709238a83c3a068b11
+DIST json-glib-1.6.6.tar.xz 1306232 BLAKE2B 93814dad74ef61ef265e348e9e145ceb63c950f1e9ecda23fbaad24e291a1cbfc690e287ccc8959fd7c056634f80815ef54fa2c75b09ebd3e158f3fa4df1c8e7 SHA512 b9a737e4ba3ecdfb9cb8f5fb751cc74e5b1553664d3088c44a1f9e5396d4037958af214dcd290ddf5af98088f46167e10e371e134e1de5cbb7aec84c5c0fd017
diff --git a/dev-libs/json-glib/json-glib-1.6.6.ebuild b/dev-libs/json-glib/json-glib-1.6.6.ebuild
new file mode 100644
index 000000000000..562120a52c5e
--- /dev/null
+++ b/dev-libs/json-glib/json-glib-1.6.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson-multilib xdg-utils
+
+DESCRIPTION="Library providing GLib serialization and deserialization for the JSON format"
+HOMEPAGE="https://wiki.gnome.org/Projects/JsonGlib"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="gtk-doc +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.54.0:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}"
+# TODO: Can we use a newer docbook-xml-dtd, or is one needed at all?
+BDEPEND="
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.20 )
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_environment_reset
+ default
+ # Disable installed-tests; this also indirectly removes build_aux/gen-installed-test.py calls, thus not needing python-any-r1.eclass
+ sed -e 's/install: true/install: false/g' -i json-glib/tests/meson.build || die
+ sed -e '/install_data/d' -i json-glib/tests/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_feature gtk-doc gtk_doc)
+ $(meson_native_true man)
+ )
+ meson_src_configure
+}