summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-10-02 23:10:02 +0200
committerMichał Górny <mgorny@gentoo.org>2016-10-02 23:51:45 +0200
commitc5e3e8dbe31188ccd9130f493cda0f549871118e (patch)
tree316c20486781b5b84695bf0a53c174fe5b04ddb7 /dev-libs/jsoncpp/jsoncpp-1.7.7.ebuild
parentprofiles: Move Zend-2.0 from MISC-FREE to FSF-APPROVED license group. (diff)
downloadgentoo-c5e3e8dbe31188ccd9130f493cda0f549871118e.tar.gz
gentoo-c5e3e8dbe31188ccd9130f493cda0f549871118e.tar.bz2
gentoo-c5e3e8dbe31188ccd9130f493cda0f549871118e.zip
dev-libs/jsoncpp: Bump to 1.7.7 (upst missed SOVERSION bump)
Diffstat (limited to 'dev-libs/jsoncpp/jsoncpp-1.7.7.ebuild')
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.7.7.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/jsoncpp/jsoncpp-1.7.7.ebuild b/dev-libs/jsoncpp/jsoncpp-1.7.7.ebuild
new file mode 100644
index 000000000000..0f1948221fa4
--- /dev/null
+++ b/dev-libs/jsoncpp/jsoncpp-1.7.7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+SRC_URI="https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0/11"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+
+DEPEND="
+ doc? (
+ app-doc/doxygen
+ ${PYTHON_DEPS}
+ )
+ test? (
+ ${PYTHON_DEPS}
+ )"
+RDEPEND=""
+
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ if use doc || use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DJSONCPP_WITH_TESTS=$(usex test)
+ -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF
+ -DJSONCPP_WITH_CMAKE_PACKAGE=ON
+
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_LIBS=OFF
+ # Follow Debian, Ubuntu, Arch convention for headers location
+ # bug #452234
+ -DINCLUDE_INSTALL_DIR="${EPREFIX}"/usr/include/jsoncpp
+ # Disable implicit ccache use
+ -DCCACHE_FOUND=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc; then
+ "${EPYTHON}" doxybuild.py --doxygen=/usr/bin/doxygen || die
+ fi
+}
+
+src_test() {
+ emake -C "${BUILD_DIR}" jsoncpp_check
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc; then
+ docinto html
+ dodoc -r dist/doxygen/jsoncpp*/.
+ fi
+}