summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-09-26 09:46:00 +0200
committerMichał Górny <mgorny@gentoo.org>2016-09-26 10:27:04 +0200
commitd7c84eac16d8b7e8da84910d022bee0396c7b0c3 (patch)
tree1e99c6561b3af0fef7a7536630a5f9e417d2e8f2 /dev-libs/jsoncpp
parentapp-arch/snappy: Stable for HPPA (bug #595026). (diff)
downloadgentoo-d7c84eac16d8b7e8da84910d022bee0396c7b0c3.tar.gz
gentoo-d7c84eac16d8b7e8da84910d022bee0396c7b0c3.tar.bz2
gentoo-d7c84eac16d8b7e8da84910d022bee0396c7b0c3.zip
dev-libs/jsoncpp: Bump to 1.7.6 (minor bugfix)
Diffstat (limited to 'dev-libs/jsoncpp')
-rw-r--r--dev-libs/jsoncpp/Manifest1
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.7.6.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-libs/jsoncpp/Manifest b/dev-libs/jsoncpp/Manifest
index 30610e642323..d639c43b1c5d 100644
--- a/dev-libs/jsoncpp/Manifest
+++ b/dev-libs/jsoncpp/Manifest
@@ -4,3 +4,4 @@ DIST jsoncpp-1.6.5.tar.gz 200507 SHA256 a2b121eaff56ec88cfd034d17685821a908d0d87
DIST jsoncpp-1.7.2.tar.gz 205391 SHA256 2179a7df19c1c6dc87e02c65b847efc914625a9b87df3e443d9610fc70c0f557 SHA512 32702147229ea7a3679654325572c38f4188f258ab6ac21f9e04059d53ef2a7cd0542ec4ec3b0e7b9089acd2b7bce389f16b9ff24b2e63e0ba2a5bcd46bab766 WHIRLPOOL a4c71f4c8cd6468f8326120bd106b50c563ab1b7a10df4874d96dd2c03f115645f1016c4e2e52f8056f58f7a40bd6bfc2a75e6aca896bdf98652b1052fde1fd8
DIST jsoncpp-1.7.4.tar.gz 205752 SHA256 10dcd0677e80727e572a1e462193e51a5fde3e023b99e144b2ee1a469835f769 SHA512 e674f6f885e2aa7258d3d3d7a14ef148b5182fd883a527b3b9d75334e778142a833bbb295796af503573b9745f889b8bc496a0b2e11dce1b9cc7f079ac538bf7 WHIRLPOOL 510915e507235d2e89d0f8097336c7910af161c2f9b39eb034be429441e457db4d5d01b8e87342654a68cf5fecdfe584ff1d1ba23fabc58012d80a9bb78e4819
DIST jsoncpp-1.7.5.tar.gz 205989 SHA256 4338c6cab8af8dee6cdfd54e6218bd0533785f552c6162bb083f8dd28bf8fbbe SHA512 c8217e390d4b15e046a6f14ad54257ac8ecc13b70073a15c502b451df25c6d8bbc645ee50bb12e67433bf2c9053e2a39544d465c19124c7b882b69dd80b70ab2 WHIRLPOOL 312522ed7d8c03a50406f6a93355fab341022ef433b553f50d6d2b9e052c645361a4cea0771f1a16189921a15d025d35f0a6a5ff251d18a9ec48faa90084bb87
+DIST jsoncpp-1.7.6.tar.gz 206060 SHA256 07cf5d4f184394ec0a9aa657dd4c13ea682c52a1ab4da2fb176cb2d5501101e8 SHA512 514428ec6eeb3082d1399024e3eca0e5f022082654e5015cdaa74234a1625e973dc43c88b572b4ca3dc9a52529e768d60f1252e3bfee3b917b990a2672595065 WHIRLPOOL 807592b000ac27d4b2004dfbe137fc812b813c64fa2a48735b39299d40def8fe4772d4624a329cb27455e4ab38b500807dbab0e58f022f0cb83db80074741e71
diff --git a/dev-libs/jsoncpp/jsoncpp-1.7.6.ebuild b/dev-libs/jsoncpp/jsoncpp-1.7.6.ebuild
new file mode 100644
index 000000000000..8f24a3626f3c
--- /dev/null
+++ b/dev-libs/jsoncpp/jsoncpp-1.7.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+SRC_URI="https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+
+DEPEND="
+ doc? (
+ app-doc/doxygen
+ ${PYTHON_DEPS}
+ )
+ test? (
+ ${PYTHON_DEPS}
+ )"
+RDEPEND=""
+
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ if use doc || use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DJSONCPP_WITH_TESTS=$(usex test)
+ -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF
+ -DJSONCPP_WITH_CMAKE_PACKAGE=ON
+
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_LIBS=OFF
+ # Follow Debian, Ubuntu, Arch convention for headers location
+ # bug #452234
+ -DINCLUDE_INSTALL_DIR="${EPREFIX}"/usr/include/jsoncpp
+ # Disable implicit ccache use
+ -DCCACHE_FOUND=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc; then
+ "${EPYTHON}" doxybuild.py --doxygen=/usr/bin/doxygen || die
+ fi
+}
+
+src_test() {
+ emake -C "${BUILD_DIR}" jsoncpp_check
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc; then
+ docinto html
+ dodoc -r dist/doxygen/jsoncpp*/.
+ fi
+}