summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-01-16 09:28:05 -0500
committerMichał Górny <mgorny@gentoo.org>2021-01-16 20:03:11 +0100
commit959c521394e5cfb40e73f6af4c174b7502d4b386 (patch)
treeb312c574b9dba0423e009463c290ed1ec0e7ce58 /dev-libs/keybinder
parentdev-ml/ocaml-migrate-parsetree: add dep (diff)
downloadgentoo-959c521394e5cfb40e73f6af4c174b7502d4b386.tar.gz
gentoo-959c521394e5cfb40e73f6af4c174b7502d4b386.tar.bz2
gentoo-959c521394e5cfb40e73f6af4c174b7502d4b386.zip
dev-libs/keybinder: EAPI 7
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/keybinder')
-rw-r--r--dev-libs/keybinder/keybinder-0.3.2-r300.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-libs/keybinder/keybinder-0.3.2-r300.ebuild b/dev-libs/keybinder/keybinder-0.3.2-r300.ebuild
index bf14d929fcf1..dae197934270 100644
--- a/dev-libs/keybinder/keybinder-0.3.2-r300.ebuild
+++ b/dev-libs/keybinder/keybinder-0.3.2-r300.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
MY_P=${PN}-3.0-${PV}
DESCRIPTION="A library for registering global keyboard shortcuts"
HOMEPAGE="https://github.com/kupferlauncher/keybinder"
SRC_URI="https://github.com/kupferlauncher/keybinder/releases/download/${PN}-3.0-v${PV}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="3"
@@ -16,12 +17,10 @@ IUSE="+introspection"
RDEPEND="x11-libs/gtk+:3[X]
x11-libs/libX11
x11-libs/libXext
- x11-libs/libXrender
+ x11-libs/libXrender"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
introspection? ( dev-libs/gobject-introspection )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
src_configure() {
local myconf=(
@@ -39,7 +38,7 @@ src_install() {
pkg_preinst() {
# remove old symlink as otherwise the files will be installed
# in the wrong directory
- if [[ -h ${EROOT%/}/usr/share/gtk-doc/html/keybinder-3.0 ]]; then
- rm "${EROOT%/}/usr/share/gtk-doc/html/keybinder-3.0" || die
+ if [[ -h ${EROOT}/usr/share/gtk-doc/html/keybinder-3.0 ]]; then
+ rm "${EROOT}/usr/share/gtk-doc/html/keybinder-3.0" || die
fi
}