summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /dev-libs/klibc
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/klibc')
-rw-r--r--dev-libs/klibc/klibc-2.0.4-r3.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/klibc/klibc-2.0.4-r3.ebuild b/dev-libs/klibc/klibc-2.0.4-r3.ebuild
index 0ce5d3b94957..15cd0619685d 100644
--- a/dev-libs/klibc/klibc-2.0.4-r3.ebuild
+++ b/dev-libs/klibc/klibc-2.0.4-r3.ebuild
@@ -155,7 +155,7 @@ src_compile() {
unset KBUILD_OUTPUT # we are using a private copy
cd "${KS}"
- emake ${defconfig} CC="${CC}" HOSTCC="${HOSTCC}" ARCH="${KLIBCASMARCH}" || die "No defconfig"
+ emake ${defconfig} CC="${CC}" HOSTCC="${HOSTCC}" ARCH="${KLIBCASMARCH}"
if [[ "${KLIBCARCH/arm}" != "${KLIBCARCH}" ]] && \
[[ "${CHOST/eabi}" != "${CHOST}" ]]; then
# The delete and insert are seperate statements
@@ -169,7 +169,7 @@ src_compile() {
"${KS}"/.config \
"${S}"/defconfig
fi
- emake prepare CC="${CC}" HOSTCC="${HOSTCC}" ARCH="${KLIBCASMARCH}" || die "Failed to prepare kernel sources for header usage"
+ emake prepare CC="${CC}" HOSTCC="${HOSTCC}" ARCH="${KLIBCASMARCH}"
cd "${S}"
@@ -196,7 +196,7 @@ src_compile() {
$(use custom-cflags || echo SKIP_)HOSTCFLAGS="${CFLAGS}" \
$(use custom-cflags || echo SKIP_)HOSTLDFLAGS="${LDFLAGS}" \
$(use custom-cflags || echo SKIP_)KLIBCOPTFLAGS="${CFLAGS}" \
- ${myargs} || die "Compile failed!"
+ ${myargs}
#SHLIBDIR="/${libdir}" \
@@ -248,7 +248,7 @@ src_install() {
$(use custom-cflags || echo SKIP_)HOSTLDFLAGS="${LDFLAGS}" \
$(use custom-cflags || echo SKIP_)KLIBCOPTFLAGS="${CFLAGS}" \
${myargs} \
- install || die "Install failed!"
+ install
#SHLIBDIR="/${libdir}" \