summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-04-15 13:29:25 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-04-15 13:30:43 -0500
commitd1de45407f81004996bc4c2536663de497c36a49 (patch)
tree770d007261d3f735a14e8cd7119580fae4b2aebf /dev-libs/leatherman/leatherman-0.11.2.ebuild
parentdev-python/tvdb_api: Add missing rdep on requests-cache (diff)
downloadgentoo-d1de45407f81004996bc4c2536663de497c36a49.tar.gz
gentoo-d1de45407f81004996bc4c2536663de497c36a49.tar.bz2
gentoo-d1de45407f81004996bc4c2536663de497c36a49.zip
dev-libs/leatherman: 0.11.2 bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/leatherman/leatherman-0.11.2.ebuild')
-rw-r--r--dev-libs/leatherman/leatherman-0.11.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/leatherman/leatherman-0.11.2.ebuild b/dev-libs/leatherman/leatherman-0.11.2.ebuild
new file mode 100644
index 000000000000..73b510ec315b
--- /dev/null
+++ b/dev-libs/leatherman/leatherman-0.11.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22"
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A C++ toolkit"
+HOMEPAGE="https://github.com/puppetlabs/leatherman"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="debug test"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.54[nls]
+ net-misc/curl
+ >=sys-devel/gcc-4.8:*"
+
+src_prepare() {
+ sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc
+ -DCMAKE_INSTALL_LOCALSTATEDIR=/var
+ )
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}