summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-30 15:36:11 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-30 15:36:22 -0500
commit1767004bbffe39fca63e3e1aeee361c4bdea4004 (patch)
treec9741cac48c4d205e489fd033104ce6d5332262e /dev-libs/leatherman/leatherman-1.12.0-r1.ebuild
parentdev-python/repoze-lru: keyworded 0.7-r1 for ia64, bug #717946 (diff)
downloadgentoo-1767004bbffe39fca63e3e1aeee361c4bdea4004.tar.gz
gentoo-1767004bbffe39fca63e3e1aeee361c4bdea4004.tar.bz2
gentoo-1767004bbffe39fca63e3e1aeee361c4bdea4004.zip
dev-libs/leatherman: remove installing vendored boost library
Closes: https://bugs.gentoo.org/721652 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/leatherman/leatherman-1.12.0-r1.ebuild')
-rw-r--r--dev-libs/leatherman/leatherman-1.12.0-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/leatherman/leatherman-1.12.0-r1.ebuild b/dev-libs/leatherman/leatherman-1.12.0-r1.ebuild
new file mode 100644
index 000000000000..30ead889cde4
--- /dev/null
+++ b/dev-libs/leatherman/leatherman-1.12.0-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils multilib
+
+DESCRIPTION="A C++ toolkit"
+HOMEPAGE="https://github.com/puppetlabs/leatherman"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+IUSE="debug static-libs test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0/${PV}"
+
+RDEPEND="net-misc/curl"
+DEPEND=">=dev-libs/boost-1.73:=[nls]
+ net-misc/curl
+ >=sys-devel/gcc-4.8:*"
+
+PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
+
+src_prepare() {
+ sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
+ sed -i '/nowide/d' CMakeLists.txt || die # vendored boost lib conflicts with boost 1.73 and above
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ )
+ if ! use static-libs; then
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=ON
+ )
+ else
+ mycmakeargs+=(
+ -DLEATHERMAN_SHARED=OFF
+ )
+ fi
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${WORKDIR}/${P}"_build/bin/leatherman_test
+}
+
+src_install() {
+ cmake-utils_src_install
+}