summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-31 11:47:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-31 11:47:45 -0500
commit3273bd78c5e306521b58b727aefb3216f8decab8 (patch)
tree762483a08f11eb64c0b62b66d563a8517ce54b41 /dev-libs/leatherman/leatherman-1.12.0-r1.ebuild
parentdev-python/Babel: Use HTTPS (diff)
downloadgentoo-3273bd78c5e306521b58b727aefb3216f8decab8.tar.gz
gentoo-3273bd78c5e306521b58b727aefb3216f8decab8.tar.bz2
gentoo-3273bd78c5e306521b58b727aefb3216f8decab8.zip
dev-libs/leatherman: fix build (avoid vendored boost nowide)
Bug: https://bugs.gentoo.org/721652 Closes: https://bugs.gentoo.org/726406 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/leatherman/leatherman-1.12.0-r1.ebuild')
-rw-r--r--dev-libs/leatherman/leatherman-1.12.0-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-libs/leatherman/leatherman-1.12.0-r1.ebuild b/dev-libs/leatherman/leatherman-1.12.0-r1.ebuild
index 30ead889cde4..9a442087026a 100644
--- a/dev-libs/leatherman/leatherman-1.12.0-r1.ebuild
+++ b/dev-libs/leatherman/leatherman-1.12.0-r1.ebuild
@@ -24,7 +24,13 @@ PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
src_prepare() {
sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
- sed -i '/nowide/d' CMakeLists.txt || die # vendored boost lib conflicts with boost 1.73 and above
+ # vendored boost lib conflicts with boost 1.73 and above
+ sed -i '/nowide/d' CMakeLists.txt
+ sed -i '/nowide/d' file_util/CMakeLists.txt || die
+ sed -i '/nowide/d' windows/CMakeLists.txt || die
+ sed -i '/nowide/d' execution/CMakeLists.txt || die
+ sed -i '/nowide/d' logging/CMakeLists.txt || die
+ sed -i '/nowide/d' util/CMakeLists.txt || die
cmake-utils_src_prepare
}